www-client/firefox: really disable Normandy service
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 30 Mar 2020 13:47:01 +0000 (15:47 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 30 Mar 2020 13:47:27 +0000 (15:47 +0200)
...while there, also disable DoH which we already disabled
in normal Firefox.

Fixes 23e30a18c ("www-client/firefox: disable Normandy service by default")
Bug: https://bugs.gentoo.org/713782
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/files/gentoo-default-prefs.js-2 [deleted file]
www-client/firefox/firefox-68.6.0-r3.ebuild [moved from www-client/firefox/firefox-68.6.0-r2.ebuild with 96% similarity]

diff --git a/www-client/firefox/files/gentoo-default-prefs.js-2 b/www-client/firefox/files/gentoo-default-prefs.js-2
deleted file mode 100644 (file)
index ffd0d7d..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-pref("app.update.enabled",                 false);
-pref("app.update.autoInstallEnabled",      false);
-pref("browser.display.use_system_colors",  true);
-pref("browser.link.open_external",         3);
-pref("general.smoothScroll",               true);
-pref("general.autoScroll",                 false);
-pref("browser.tabs.tabMinWidth",           15);
-pref("browser.backspace_action",           0);
-pref("browser.urlbar.hideGoButton",        true);
-pref("accessibility.typeaheadfind",        true);
-pref("browser.shell.checkDefaultBrowser",  false); 
-pref("browser.EULA.override",              true); 
-pref("general.useragent.vendor",           "Gentoo");
-pref("general.useragent.locale",           "chrome://global/locale/intl.properties");
-pref("intl.locale.requested",              "");
-pref("extensions.autoDisableScopes",       0);
-pref("layout.css.dpi",                     0);
similarity index 96%
rename from www-client/firefox/firefox-68.6.0-r2.ebuild
rename to www-client/firefox/firefox-68.6.0-r3.ebuild
index a10f2faf8a77c23eaf02e17f2780c9c13acf91f1..24ceeba5ece5cdd1657658bfd671663307dd02ed 100644 (file)
@@ -641,7 +641,7 @@ src_install() {
        pax-mark m "${BUILD_OBJ_DIR}"/dist/bin/xpcshell
 
        # Add our default prefs for firefox
-       cp "${FILESDIR}"/gentoo-default-prefs.js-2 \
+       cp "${FILESDIR}"/gentoo-default-prefs.js-3 \
                "${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
                || die
 
@@ -852,22 +852,37 @@ pkg_postinst() {
                elog
        fi
 
-       local show_normandy_information
+       local show_doh_information show_normandy_information
 
        if [[ -z "${REPLACING_VERSIONS}" ]] ; then
-               # New install
+               # New install; Tell user that DoH is disabled by default
+               show_doh_information=yes
                show_normandy_information=yes
        else
                local replacing_version
                for replacing_version in ${REPLACING_VERSIONS} ; do
-                       if ver_test "${replacing_version}" -lt 68.6.0-r2 ; then
+                       if ver_test "${replacing_version}" -lt 68.6.0-r3 ; then
+                               # Tell user only once about our DoH default
+                               show_doh_information=yes
+                       fi
+
+                       if ver_test "${replacing_version}" -lt 68.6.0-r3 ; then
                                # Tell user only once about our Normandy default
                                show_normandy_information=yes
-                               break
                        fi
                done
        fi
 
+       if [[ -n "${show_doh_information}" ]] ; then
+               elog
+               elog "Note regarding Trusted Recursive Resolver aka DNS-over-HTTPS (DoH):"
+               elog "Due to privacy concerns (encrypting DNS might be a good thing, sending all"
+               elog "DNS traffic to Cloudflare by default is not a good idea and applications"
+               elog "should respect OS configured settings), \"network.trr.mode\" was set to 5"
+               elog "(\"Off by choice\") by default."
+               elog "You can enable DNS-over-HTTPS in ${PN^}'s preferences."
+       fi
+
        # bug 713782
        if [[ -n "${show_normandy_information}" ]] ; then
                elog