dev-python/flufl-bounce: Bump and Python 3.7.
authorHanno Böck <hanno@gentoo.org>
Fri, 7 Feb 2020 08:35:07 +0000 (09:35 +0100)
committerHanno Böck <hanno@gentoo.org>
Fri, 7 Feb 2020 08:35:07 +0000 (09:35 +0100)
Bug: https://bugs.gentoo.org/705332
Signed-off-by: Hanno Böck <hanno@gentoo.org>
Package-Manager: Portage-2.3.87, Repoman-2.3.20

dev-python/flufl-bounce/Manifest
dev-python/flufl-bounce/flufl-bounce-3.0.1.ebuild [new file with mode: 0644]

index 81fc1c2567fd7cf2fa7dc617eb87b7e21fe420f2..74d2c36e71081159ad41d59c77c2f96bdd538b27 100644 (file)
@@ -1 +1,2 @@
+DIST flufl-bounce-3.0.1.tar.gz 100217 BLAKE2B d5620d73513a7e5bbfffb212f13bba34ce199a129a217873a8237d8456a7a1854d78cb9b06e4ee763d4dcfdcfdc185e0d67eb3be82ad829c054baced8acfc25c SHA512 9a8d0dec98f8699fd3dff62f5dd831ab5754f11d246b750cfed8ae7ebb771c3c7c1abd4fcceb0f8aa052653802c6e6e5a7bd4711e63b9095ede238817a3cd146
 DIST flufl-bounce-3.0.tar.gz 89156 BLAKE2B 02ff80f4ebe42e15c9e6a7ed192d9a032e800b2b1da874837da5e6d5c156f50455795469c1c782bc7070cba3ab66d11ee576b8e95881a78bd1a479c825939dbd SHA512 f6effe38c80e1e5e1119d7951a1a32bb9b91fc52db0887eee4ebb74e005ad5cf48351311985a3169649301efe9273d3fe480b3dded7eff3b77b73312d0416f45
diff --git a/dev-python/flufl-bounce/flufl-bounce-3.0.1.ebuild b/dev-python/flufl-bounce/flufl-bounce-3.0.1.ebuild
new file mode 100644 (file)
index 0000000..7e4fe68
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Email bounce detectors."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.bounce"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       dev-python/atpublic[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]
+"