net-fs/tahoe-lafs: version bump to 1.10.2
authorJulian Ospald <hasufell@gentoo.org>
Tue, 11 Aug 2015 01:39:06 +0000 (03:39 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 11 Aug 2015 01:39:06 +0000 (03:39 +0200)
net-fs/tahoe-lafs/Manifest
net-fs/tahoe-lafs/tahoe-lafs-1.10.2.ebuild [new file with mode: 0644]

index 806bbced4399db8324f4e68f0d15d182a7a6d029..36590914d4e380ba964bb42a982c45a3e1b3dcb0 100644 (file)
@@ -1 +1,2 @@
 DIST allmydata-tahoe-1.10.0.tar.bz2 1174044 SHA256 9c5516700fe95fdf8c57eca1e2a7b4aebf2de9a4d327d50afd684ebf833ccfe2 SHA512 664e1cbff3061c54f750af97f74a9fd6f1a16d5f6da73db4cb0e80bc01c97a4e18bf17818c9642e0d95b4a0b3669dc8648f800e63c4793ffb9f2f1bd6de2d461 WHIRLPOOL 9f579783cf46374c329f209898ebe34f28bc3e851ed4ec3eabe7cbb5bd2aac4a7b5aad925b1c688a46dec33f218c8e539dd2d464bdda82c67f685887f5aebf18
+DIST allmydata-tahoe-1.10.2.tar.bz2 1378204 SHA256 fed5d719c966d9528a45e8ad66e6c8ff3dcb3c06db94775194c7c75566047be7 SHA512 79d4e3395aa7ef8e1e7c97eebdfcb75b3b36edb75aa5d5f805c568b842b9b2f4ea5f8529dbf32fbdd9cc467cf82f153aca09310bc3b69fa00efae7be8a7bc198 WHIRLPOOL d38a362105118113aaaf34c429c4b611e37ebf10d983dff1a4a117f6802671df78805ac1950b1c01279d36d1c87bc3976fec498580117d6f9bc46912a00b792f
diff --git a/net-fs/tahoe-lafs/tahoe-lafs-1.10.2.ebuild b/net-fs/tahoe-lafs/tahoe-lafs-1.10.2.ebuild
new file mode 100644 (file)
index 0000000..85b865b
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_PN="allmydata-tahoe"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Secure, decentralized, data store"
+HOMEPAGE="http://tahoe-lafs.org/trac/tahoe-lafs"
+SRC_URI="http://tahoe-lafs.org/source/tahoe-lafs/releases/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+       >=dev-python/characteristic-14.0.0[${PYTHON_USEDEP}]
+       >=dev-python/foolscap-0.8.0[${PYTHON_USEDEP}]
+       dev-python/nevow[${PYTHON_USEDEP}]
+       >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
+       dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+       dev-python/pycrypto[${PYTHON_USEDEP}]
+       dev-python/pycryptopp[${PYTHON_USEDEP}]
+       >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+       dev-python/pyutil[${PYTHON_USEDEP}]
+       dev-python/service_identity[${PYTHON_USEDEP}]
+       dev-python/simplejson[${PYTHON_USEDEP}]
+       >=dev-python/twisted-core-13.0.0[${PYTHON_USEDEP}]
+       dev-python/zbase32[${PYTHON_USEDEP}]
+       dev-python/zfec[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       rm -r setuptools* setup.cfg || die
+       distutils-r1_src_prepare
+}
+
+src_install() {
+       distutils-r1_src_install
+       use doc && dodoc -r docs/*
+}
+
+pkg_postinst() {
+       elog
+       elog "optional dependencies:"
+       elog "  dev-python/twisted-conch (for sftp access)"
+       elog
+}