media-libs/openimageio: QA changes
authorlg188 <lander.ghekiere@gmail.com>
Mon, 7 Jan 2019 08:52:15 +0000 (09:52 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 7 Jan 2019 12:38:14 +0000 (13:38 +0100)
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
media-libs/openimageio/openimageio-1.8.17.ebuild

index 7e8ccfa610340e86b4ae0209b829eb3854c45d87..a0050a66933dcc4c23ddfefcc3f0284fcb0e0470 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
 
 inherit cmake-utils python-single-r1
 
@@ -67,12 +67,12 @@ DEPEND="${RDEPEND}
 
 DOCS=( CHANGES.md CREDITS.md README.md src/doc/${PN}.pdf )
 
+S="${WORKDIR}/oiio-Release-${PV}"
+
 pkg_setup() {
        use python && python-single-r1_pkg_setup
 }
 
-S="${WORKDIR}/oiio-Release-${PV}"
-
 src_configure() {
        # Build with SIMD support
        local cpufeature