net-analyzer/nodebrain: pkgmove
authorJeroen Roovers <jer@gentoo.org>
Sat, 26 Sep 2015 05:50:20 +0000 (07:50 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sat, 26 Sep 2015 05:53:43 +0000 (07:53 +0200)
Package-Manager: portage-2.2.20.1

net-analyzer/nodebrain/Manifest [new file with mode: 0644]
net-analyzer/nodebrain/files/nodebrain-0.8.14-include.patch [new file with mode: 0644]
net-analyzer/nodebrain/metadata.xml [new file with mode: 0644]
net-analyzer/nodebrain/nodebrain-0.9.03.ebuild [new file with mode: 0644]
net-analyzer/nodebrain/nodebrain-0.9.04.ebuild [new file with mode: 0644]

diff --git a/net-analyzer/nodebrain/Manifest b/net-analyzer/nodebrain/Manifest
new file mode 100644 (file)
index 0000000..09443dd
--- /dev/null
@@ -0,0 +1,2 @@
+DIST nodebrain-0.9.03.tar.gz 2485735 SHA256 e9fce23525da8c6b3e553492b724eb2122faf22aed92ed45b15c6018eb643fef SHA512 bf81ef4be1518b72d8ef0cccf42747cfe2926ed6cecfde97c05c161c2f2d00525d07da2e24b1c05debb84fa6f35dca7d7dbbc3292471f41dd322ea80175fb96c WHIRLPOOL 0ae2c4f8085cbc725662ee758768a7684523350ebe59ab6f50f374c6b5d0b55588697f84bb395bf946eaa3546a052f08f4fa067532b42eafcf84a9a84baecd7c
+DIST nodebrain-0.9.04.tar.gz 2475665 SHA256 4fd936050fa08d5639312fca32528034b82e2c4caf10c23126db6bb8d0eb0175 SHA512 a6cbebef09569d2d086954fc06b7a0bbc2828a5041289fdb7b537bd75b354610f3cf28baded5fce9679d89ffea3e245ab59323a00d060e98819d367775fd5226 WHIRLPOOL b7bc9f4417ac14574c7a3db8be46a695cbbac66cc9bdc7ceff7346002e7849a919750089e16fc618ad9bde996b69b832ffe48c903b4b41b5ad52948bf3cc09ee
diff --git a/net-analyzer/nodebrain/files/nodebrain-0.8.14-include.patch b/net-analyzer/nodebrain/files/nodebrain-0.8.14-include.patch
new file mode 100644 (file)
index 0000000..c34965b
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/lib/nbbfi.c
++++ b/lib/nbbfi.c
+@@ -197,6 +197,7 @@
+ *=============================================================================
+ */
+ #include <nb/nbi.h>
++#include <ctype.h> /* isdigit() */
+ /**************************************************************************
+ * Index Routines
+--- a/lib/nbkit.c
++++ b/lib/nbkit.c
+@@ -51,6 +51,7 @@
+ #include <pwd.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <stdlib.h> /* system() */
+ static int nbKitUsage(void){
+     printf("Usage:\n");
+--- a/module/webster/nb_webster.c
++++ b/module/webster/nb_webster.c
+@@ -78,6 +78,7 @@
+ */
+ #include "config.h"
+ #include <nb/nb.h>
++#include <ctype.h> /* isalnum() */
+ #if defined(WIN32)
diff --git a/net-analyzer/nodebrain/metadata.xml b/net-analyzer/nodebrain/metadata.xml
new file mode 100644 (file)
index 0000000..d646f58
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>netmon</herd>
+       <upstream>
+               <remote-id type="sourceforge">nodebrain</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nodebrain/nodebrain-0.9.03.ebuild b/net-analyzer/nodebrain/nodebrain-0.9.03.ebuild
new file mode 100644 (file)
index 0000000..0afe27b
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Nodebrain is a tool to monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+CDEPEND="dev-libs/libedit"
+DEPEND="
+       ${CDEPEND}
+       dev-lang/perl
+       virtual/pkgconfig
+       sys-apps/texinfo
+"
+RDEPEND="
+       ${CDEPEND}
+       !sys-boot/netboot
+       !www-apps/nanoblogger
+"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-0.8.14-include.patch
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               --include=/usr/include
+}
+
+src_install() {
+       default
+       use static-libs || prune_libtool_files
+       dodoc AUTHORS NEWS README THANKS sample/*
+       dohtml html/*
+}
diff --git a/net-analyzer/nodebrain/nodebrain-0.9.04.ebuild b/net-analyzer/nodebrain/nodebrain-0.9.04.ebuild
new file mode 100644 (file)
index 0000000..0afe27b
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Nodebrain is a tool to monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+CDEPEND="dev-libs/libedit"
+DEPEND="
+       ${CDEPEND}
+       dev-lang/perl
+       virtual/pkgconfig
+       sys-apps/texinfo
+"
+RDEPEND="
+       ${CDEPEND}
+       !sys-boot/netboot
+       !www-apps/nanoblogger
+"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-0.8.14-include.patch
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               --include=/usr/include
+}
+
+src_install() {
+       default
+       use static-libs || prune_libtool_files
+       dodoc AUTHORS NEWS README THANKS sample/*
+       dohtml html/*
+}