dev-libs/level-zero: Remove redundant check for C++14 support
authorMarek Szuba <marecki@gentoo.org>
Thu, 23 Apr 2020 21:05:08 +0000 (22:05 +0100)
committerMarek Szuba <marecki@gentoo.org>
Thu, 23 Apr 2020 21:10:51 +0000 (22:10 +0100)
At this point in time we would be hard pressed to find a C++ compiler in
the tree without *C++17* support, let alone C++14.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-libs/level-zero/level-zero-0.91.10.ebuild

index 3624672b5a4d59c19246651ae4632fa8359b4ad2..99ac29609fcd286f3b7bd397e6af76eebb6866cf 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake flag-o-matic
+inherit cmake
 
 DESCRIPTION="oneAPI Level Zero headers, loader and validation layer"
 HOMEPAGE="https://github.com/oneapi-src/level-zero"
@@ -18,17 +18,6 @@ DEPEND="dev-util/opencl-headers"
 
 RESTRICT="!test? ( test )"
 
-pkg_pretend() {
-       if [[ ${MERGE_TYPE} != binary ]]; then
-               if ! test-flag-CXX -std=c++14; then
-                       eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
-                       eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
-                       eerror "to gcc-4.9 or an equivalent version supporting C++14."
-                       die "Currently active compiler does not support -std=c++14"
-               fi
-       fi
-}
-
 src_prepare() {
        cmake_src_prepare
        # According to upstream, release tarballs should contain this file