app-portage/nattka: Bump to 0.0.7
authorMichał Górny <mgorny@gentoo.org>
Tue, 7 Apr 2020 18:50:29 +0000 (20:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 7 Apr 2020 19:00:28 +0000 (21:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/nattka/Manifest
app-portage/nattka/nattka-0.0.7.ebuild [new file with mode: 0644]

index 8d9805c43f133058ad59671fe20fe956f6371212..edc975e67103a82a1f9260c1b710c6114ffddd4c 100644 (file)
@@ -1 +1,2 @@
 DIST nattka-0.0.6.tar.gz 60753 BLAKE2B cd6d843c34411d4cd3dea32a416dc4d3ade0de3331606cb141804eaaf3ef2f2f0d83160927c701c9266c0bb604180d28631d5c809b11a2332829b1510ddaee18 SHA512 b0a5f0d11f0469358464e73dd813b07568bbdccfc66e2c85db8510c7a335b289c7bb51ee2f11fbca84f73453e9f45349882d812859c54ae725afd9580a320135
+DIST nattka-0.0.7.tar.gz 64207 BLAKE2B df144feb93ccef79cf9236850c8f286c0cbabfb8ae16bf280cc95552f4e3af2b91872a8dbd624714066147a5af0dcda7085ee828a390f6791da287d0c25a5b1a SHA512 088b3dd470e1c0229278fd2db48d81702572c9294f25ff8f7a72b28866df607aff58f507c9bac9f8b86f4126cc2b6a520761553d38b5f98607f8014132a3d8f0
diff --git a/app-portage/nattka/nattka-0.0.7.ebuild b/app-portage/nattka/nattka-0.0.7.ebuild
new file mode 100644 (file)
index 0000000..cf9543a
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-util/pkgcheck[${PYTHON_USEDEP}]
+       dev-vcs/git
+       sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest