dev-ml/type-conv: bump to 113.00.00
authorAlexis Ballier <aballier@gentoo.org>
Sat, 19 Sep 2015 12:11:58 +0000 (14:11 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 19 Sep 2015 14:03:01 +0000 (16:03 +0200)
Package-Manager: portage-2.2.20.1

dev-ml/type-conv/Manifest
dev-ml/type-conv/type-conv-113.00.00.ebuild [new file with mode: 0644]

index bc78beea19bfed96c3e21aaf2ae137204e0f74b2..68e5b46fb2340b5ec016243c577c979f0e63d9de 100644 (file)
@@ -1 +1,2 @@
 DIST type_conv-112.01.02.tar.gz 64095 SHA256 342a241a43a2d494739244c8e41624bef25dfae809ebf15577d817ebb67f3890 SHA512 68acc043dc33db3928c6078c8bd5eac2f3346c39af2e7ff4605a397b3322032da5ae8be4ef8a1eba440b57c048f55b74ba47de4fc08cefe934eba34f35e235a4 WHIRLPOOL a53009600678d75405d6648030efe84896cf9cdbcde261265608691b9f6a8d28340acaf414e7de48b52c27b0b030a294612b80e1573759f0e4fdd70bd3142dcb
+DIST type_conv-113.00.00.tar.gz 64297 SHA256 52bf5bc316f24411ad8f334b07b98a852071c92d0f95914c5d933ae7c65feb43 SHA512 bd9a455b4c30b5ba95a6cd4032bac61f69f9657a8e583c72b74e2a1974b0ad5b7488c5ba173ab880937ff0b8fa79712f761436fe1ffe7a45f8301f37cfb5a825 WHIRLPOOL 1dff5fe344c747a2525615a4c9379fb9b392fec01702f50ae80c614d1d0445ebb04558b2ca1c605a0396bbecc66e97e4d61f6a4259d304b556e566929a733fcd
diff --git a/dev-ml/type-conv/type-conv-113.00.00.ebuild b/dev-ml/type-conv/type-conv-113.00.00.ebuild
new file mode 100644 (file)
index 0000000..8acec6e
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Mini library required for some other preprocessing libraries"
+HOMEPAGE="http://janestreet.github.io/"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ocaml-4.02[ocamlopt?]
+       dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+       >=dev-ml/findlib-1.3.2"
+
+DOCS=( "README.md" "CHANGES.md" )
+
+S="${WORKDIR}/${MY_P}"