Compile fix for parallel make.
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 5 Jan 2007 20:01:58 +0000 (20:01 +0000)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 5 Jan 2007 20:01:58 +0000 (20:01 +0000)
Package-Manager: portage-2.1.2_rc4-r6

media-libs/libexif/ChangeLog
media-libs/libexif/files/libexif-0.6.13-parallel-build.patch [new file with mode: 0644]
media-libs/libexif/libexif-0.6.13-r1.ebuild

index 4703bec20c928003b997fa11e2abb13418ac9ed9..fd278457e9d2a8c47ecced31fb4173e30ce1c129 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for media-libs/libexif
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.60 2006/10/17 20:32:37 kloeri Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/ChangeLog,v 1.61 2007/01/05 20:01:58 robbat2 Exp $
+
+  05 Jan 2007; Robin H. Johnson <robbat2@gentoo.org>
+  +files/libexif-0.6.13-parallel-build.patch, libexif-0.6.13-r1.ebuild:
+  Compile fix for parallel make.
 
   17 Oct 2006; Bryan Ã˜stergaard <kloeri@gentoo.org>
   libexif-0.6.13-r1.ebuild:
diff --git a/media-libs/libexif/files/libexif-0.6.13-parallel-build.patch b/media-libs/libexif/files/libexif-0.6.13-parallel-build.patch
new file mode 100644 (file)
index 0000000..3502858
--- /dev/null
@@ -0,0 +1,38 @@
+From: Robin H. Johnson <robbat2@gentoo.org>
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+Initial-Package-Version: 0.6.13
+Date: Fri Jan  5 11:57:33 PST 2007
+Origin: n/a
+Description: Fix the doc Makefile for parallel builds.
+
+diff -Nuar libexif-0.6.13.orig/doc/Makefile.am libexif-0.6.13/doc/Makefile.am
+--- libexif-0.6.13.orig/doc/Makefile.am        2007-01-05 11:55:47.000000000 -0800
++++ libexif-0.6.13/doc/Makefile.am     2007-01-05 11:55:21.000000000 -0800
+@@ -9,15 +9,13 @@
+ DOXYGEN_UPLOAD = $(HTML_APIDOC_DIR).uploaded $(HTML_APIDOC_INTERNALS_DIR).uploaded
+ # FIXME: Depending on the source files would be sufficient...
+-$(HTML_APIDOC_DIR).stamp: Doxyfile $(top_builddir)/libexif/libexif.la
++# Generate the public version before running this version
++$(HTML_APIDOC_INTERNALS_DIR).stamp: Doxyfile-internals $(top_builddir)/libexif/libexif.la $(DOXYGEN_OUTPUT_DIR).stamp
+       doxygen $<
+       echo > $@
+ # FIXME: Depending on the source files would be sufficient...
+-$(HTML_APIDOC_INTERNALS_DIR).stamp: Doxyfile-internals $(top_builddir)/libexif/libexif.la
+-      doxygen $<
+-      echo > $@
+-
++# This generates HTML_APIDOC_DIR as well as DOXYGEN_OUTPUT_DIR
+ $(DOXYGEN_OUTPUT_DIR).stamp: Doxyfile $(top_builddir)/libexif/libexif.la
+       doxygen $<
+       echo > $@
+@@ -28,7 +26,7 @@
+ $(HTML_APIDOC_DIR).tar.gz: $(DOXYGEN_OUTPUT_DIR).stamp
+       (cd $(DOXYGEN_OUTPUT_DIR) && $(AMTAR) chof - $(HTML_APIDOC_DIR) | GZIP=--best gzip -c) > $@
+-$(HTML_APIDOC_INTERNALS_DIR).tar.gz: $(DOXYGEN_OUTPUT_DIR).stamp
++$(HTML_APIDOC_INTERNALS_DIR).tar.gz: $(DOXYGEN_OUTPUT_DIR).stamp $(HTML_APIDOC_INTERNALS_DIR).stamp
+       (cd $(DOXYGEN_OUTPUT_DIR) && $(AMTAR) chof - $(HTML_APIDOC_INTERNALS_DIR) | GZIP=--best gzip -c) > $@
+ DOC_APIDOC_HTML = api.html
index 6cfb7e69808d337fc9b60c3fffd9e444217db10b..5322424c2e1973abbd16856cb683f5436b89a122 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.13-r1.ebuild,v 1.7 2006/10/17 20:32:37 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.6.13-r1.ebuild,v 1.8 2007/01/05 20:01:58 robbat2 Exp $
 
 inherit eutils libtool
 
@@ -23,6 +23,7 @@ src_unpack() {
 
        cd ${S}
        epatch ${FILESDIR}/libexif-0.6.13-doxygen.patch
+       epatch ${FILESDIR}/libexif-0.6.13-parallel-build.patch
        epatch "${FILESDIR}/${P}-pkgconfig.patch"
 
        # The libexif hackers made a goof on the soname versioning.