app-emulation/xen-tools: [QA] Fix missing trailing slash
authorDavid Seifert <soap@gentoo.org>
Sun, 11 Aug 2019 14:43:56 +0000 (16:43 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 11 Aug 2019 14:43:56 +0000 (16:43 +0200)
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
app-emulation/xen-tools/xen-tools-4.10.3-r2.ebuild
app-emulation/xen-tools/xen-tools-4.11.1-r5.ebuild
app-emulation/xen-tools/xen-tools-4.12.0-r3.ebuild

index dc0192b621ed7c19f2fcd17ce51eeed96b8d3529..11abf9ebb62f42216b7c5c9d49323a5a5d7dd7bd 100644 (file)
@@ -392,7 +392,7 @@ src_install() {
                XEN_PYTHON_NATIVE_INSTALL=y install-tools
 
        # Created at runtime
-       rm -rv "${ED%/}/var/run" || die
+       rm -rv "${ED}/var/run" || die
 
        # Fix the remaining Python shebangs.
        python_fix_shebang "${D}"
@@ -428,7 +428,7 @@ src_install() {
 
        # For -static-libs wrt Bug 384355
        if ! use static-libs; then
-               rm -f "${D}"/usr/$(get_libdir)/*.a "${D}"usr/$(get_libdir)/ocaml/*/*.a
+               rm -f "${D}"/usr/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/ocaml/*/*.a
        fi
 
        # for xendomains
index 0dd08b6ae28207c6141899779ad59fa7108ab27b..aa27319fb1011bb5669f0eb190cbf393259ec550 100644 (file)
@@ -398,7 +398,7 @@ src_install() {
                XEN_PYTHON_NATIVE_INSTALL=y install-tools
 
        # Created at runtime
-       rm -rv "${ED%/}/var/run" || die
+       rm -rv "${ED}/var/run" || die
 
        # Fix the remaining Python shebangs.
        python_fix_shebang "${D}"
@@ -434,7 +434,7 @@ src_install() {
 
        # For -static-libs wrt Bug 384355
        if ! use static-libs; then
-               rm -f "${D}"/usr/$(get_libdir)/*.a "${D}"usr/$(get_libdir)/ocaml/*/*.a
+               rm -f "${D}"/usr/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/ocaml/*/*.a
        fi
 
        # for xendomains
index a0b3c419501914461279b1f7fe9d3040e96ca49b..8a13631173e472b51cefbf07a4a85d18ab756650 100644 (file)
@@ -415,7 +415,7 @@ src_install() {
                XEN_PYTHON_NATIVE_INSTALL=y install-tools
 
        # Created at runtime
-       rm -rv "${ED%/}/var/run" || die
+       rm -rv "${ED}/var/run" || die
 
        # Fix the remaining Python shebangs.
        python_fix_shebang "${D}"
@@ -451,7 +451,7 @@ src_install() {
 
        # For -static-libs wrt Bug 384355
        if ! use static-libs; then
-               rm -f "${D}"/usr/$(get_libdir)/*.a "${D}"usr/$(get_libdir)/ocaml/*/*.a
+               rm -f "${D}"/usr/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/ocaml/*/*.a
        fi
 
        # for xendomains