Fixed pre-stripping of binaries; bug #137822.
authorLars Weiler <pylon@gentoo.org>
Sun, 3 Dec 2006 17:22:25 +0000 (17:22 +0000)
committerLars Weiler <pylon@gentoo.org>
Sun, 3 Dec 2006 17:22:25 +0000 (17:22 +0000)
Package-Manager: portage-2.1.2_rc2-r4

games-simulation/openttd/ChangeLog
games-simulation/openttd/openttd-0.4.8.ebuild

index a5aa95fadbd5a50a9fb9cc4429184c474e6f1214..f1dada5672329396018d726f9e0c121cafa5c4a6 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-simulation/openttd
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.29 2006/10/06 16:36:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.30 2006/12/03 17:22:25 pylon Exp $
+
+  03 Dec 2006; Lars Weiler <pylon@gentoo.org> -openttd-0.4.0.1-r1.ebuild,
+  openttd-0.4.8.ebuild:
+  Fixed pre-stripping of binaries; bug #137822.
 
   06 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org>
   -openttd-0.4.7.ebuild, -openttd-0.4.8_rc1.ebuild,
index aa82c3dbd7c2c423c54e35ffdf967e3ae24b7c7a..324b28bfead7b5c76ac5fef994bd836be2ff36e1 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.4.8.ebuild,v 1.5 2006/08/21 07:58:38 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.4.8.ebuild,v 1.6 2006/12/03 17:22:25 pylon Exp $
 
 inherit eutils games
 
@@ -35,6 +35,8 @@ src_unpack() {
                unpack ${SCENARIOS_A}
        fi
        cd ${S}
+       # Don't pre-strip binaries (bug #137822)
+       sed -i '/+= -s$/s/-s//' Makefile || die "sed failed"
 }
 
 src_compile() {