dev-python/flask-sphinx-themes: initial commit, required for Flask-BabelEx
authorTiziano Müller <dev-zero@gentoo.org>
Sun, 6 Nov 2016 10:57:46 +0000 (11:57 +0100)
committerTiziano Müller <dev-zero@gentoo.org>
Sun, 6 Nov 2016 11:23:48 +0000 (12:23 +0100)
Package-Manager: portage-2.3.0

dev-python/flask-sphinx-themes/Manifest [new file with mode: 0644]
dev-python/flask-sphinx-themes/files/flask-sphinx-themes-1.0.1-python2-encoding-kw.patch [new file with mode: 0644]
dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild [new file with mode: 0644]
dev-python/flask-sphinx-themes/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/flask-sphinx-themes/Manifest b/dev-python/flask-sphinx-themes/Manifest
new file mode 100644 (file)
index 0000000..27497f3
--- /dev/null
@@ -0,0 +1 @@
+DIST Flask-Sphinx-Themes-1.0.1.tar.gz 8150 SHA256 a83eebca95fc5b8adbae4e65926961912edd52a1b6a422c0301a750d1ae31747 SHA512 65ab8dcc75697fc61e6f6f78ec497ece99eba19c48e778f79e3883079cd0d5e42a2e0f1cf3d656dedf92423d1758caf6fd2279907dd87b50f3a79700f66c5e65 WHIRLPOOL 8d918d348c72e5ce4c47c50a0652299624a71cae7d1f7a3740360101269c04c5757682f7237b21b2be04260f606b1157f8f96d55b364f4c617e2c05a3da24226
diff --git a/dev-python/flask-sphinx-themes/files/flask-sphinx-themes-1.0.1-python2-encoding-kw.patch b/dev-python/flask-sphinx-themes/files/flask-sphinx-themes-1.0.1-python2-encoding-kw.patch
new file mode 100644 (file)
index 0000000..5f4f5d4
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index d14f27b..40bffcc 100755
+--- a/setup.py
++++ b/setup.py
+@@ -1,6 +1,7 @@
+ #!/usr/bin/env python
+ import os
+ import re
++from io import open  # for python 2 compat (missing 'encoding' kw)
+ from setuptools import setup
diff --git a/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild b/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..61a7be0
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Sphinx-Themes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sphinx Themes for Flask related projects and Flask itself"
+HOMEPAGE="https://github.com/pallets/flask-sphinx-themes https://pypi.python.org/pypi/Flask-Sphinx-Themes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-python2-encoding-kw.patch" )
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/flask-sphinx-themes/metadata.xml b/dev-python/flask-sphinx-themes/metadata.xml
new file mode 100644 (file)
index 0000000..9a38b60
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">Flask-Sphinx-Themes</remote-id>
+  </upstream>
+</pkgmetadata>