dev-python/rebulk: Remove the live ebuild
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 09:45:04 +0000 (10:45 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 11:05:37 +0000 (12:05 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/rebulk/rebulk-9999.ebuild [deleted file]

diff --git a/dev-python/rebulk/rebulk-9999.ebuild b/dev-python/rebulk/rebulk-9999.ebuild
deleted file mode 100644 (file)
index 8882545..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Python library that performs advanced searches in strings"
-HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.org/project/rebulk/"
-EGIT_REPO_URI="https://github.com/Toilal/${PN}.git"
-
-LICENSE="MIT Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       # Remove base64-encoded zip archive with pytest.
-       rm runtests.py || die
-
-       # Disable unconditional dependency on dev-python/pytest-runner.
-       sed -i -e "s|'pytest-runner'||g" setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       esetup.py test
-}