net-misc/minidlna: Version bump (bug 560866, thanks mrue), add symlink /usr/bin/minid...
authorMichael Weber <xmw@gentoo.org>
Sat, 3 Oct 2015 16:49:23 +0000 (18:49 +0200)
committerMichael Weber <xmw@gentoo.org>
Sat, 3 Oct 2015 16:50:48 +0000 (18:50 +0200)
Package-Manager: portage-2.2.21

net-misc/minidlna/Manifest
net-misc/minidlna/minidlna-1.1.5.ebuild [new file with mode: 0644]

index dfe3eaabd9ba82bd190e6c7dd3f491f4226da07b..7a5cd8d0a6f3d71a4aaa7bcf245ebd094abf705f 100644 (file)
@@ -1,3 +1,4 @@
 DIST minidlna-1.1.3.tar.gz 481789 SHA256 ed42d5cadf9488a95a0107341918879ef8ce4c650e19337688c46cdcd484bc4e SHA512 3b3c28ed17325a1d2c461c51c7958fcc7fd02b71332a952e06f0ad8bca04f8ff58a74bb3d221ad432282c7289953bd31c213c2703008fb36037c39a743001aa9 WHIRLPOOL 4ac0a4344feb026d483562d5711f3f3ce4f70d68d9b043ec54e7d3667c7b38e2d1b7df2cbb2a5c9d05d4afc29182fe65c95389530b187000e496902734bb498e
 DIST minidlna-1.1.4.tar.gz 494478 SHA256 9814c04a2c506a0dd942c4218d30c07dedf90dabffbdef2d308a3f9f23545314 SHA512 24c2d82222798278d60faa46c6d7b19e44a91868da869f7d2aa2bf3c68e343a6c2a323f67223ea69242919047b08f059ed9c7a49b0b516384244acd98b51db4e WHIRLPOOL 5f82dd2130086e90784b05d67037e9c40e20b539ddc1bfb3733910beee44578027d9c245aa1f6117ba05b3c039a2b32125ea561f71c63cf0e422664e7067007f
+DIST minidlna-1.1.5.tar.gz 488191 SHA256 8477ad0416bb2af5cd8da6dde6c07ffe1a413492b7fe40a362bc8587be15ab9b SHA512 2a8eaa42fcda6f98648f1726af5cdba6d2358c386440dd0de933364cfbd1ced2fee5f883033e1a5a692b760749beb2c12798020a3591ddcea22663102d4f3dfa WHIRLPOOL 8ed8fd62fb063b042a234c8647fa05c65e4f1e331a66efae8f361002f5cedcd2706d777348332075e3263e0d8bbde7794dd84fc400dfe3a656e5d70952427669
 DIST minidlna-gentoo-artwork.patch.xz 49372 SHA256 37ae7228b07b7c81c8962c5dc88a41ed1691bdf1b019b654a9fc93ac1da0c7ce SHA512 3bdaadc2a2331e9ebf37ed80d1de7cebd6307ab068dc9cf067159b2c0754a765b2076c07e988602af4dd2d6c49c819da8a1f668258950e15592027b353f22b5e WHIRLPOOL e243b9b6a002af5e3ee1bb196239790ff86724624ebccb34c84ac072426341db6b5f44e455d13657d5284220fe2688ddf3a2ec0212a7b86525eb02a6c080af80
diff --git a/net-misc/minidlna/minidlna-1.1.5.ebuild b/net-misc/minidlna/minidlna-1.1.5.ebuild
new file mode 100644 (file)
index 0000000..ef55959
--- /dev/null
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils linux-info systemd toolchain-funcs user
+
+DESCRIPTION="DLNA/UPnP-AV compliant media server"
+HOMEPAGE="http://minidlna.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz
+       https://dev.gentoo.org/~xmw/${PN}-gentoo-artwork.patch.xz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="netgear readynas"
+
+RDEPEND="dev-db/sqlite:3
+       media-libs/flac
+       media-libs/libexif
+       media-libs/libid3tag
+       media-libs/libogg
+       media-libs/libvorbis
+       virtual/ffmpeg
+       virtual/jpeg:0"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+CONFIG_CHECK="~INOTIFY_USER"
+
+pkg_setup() {
+       local my_is_new="yes"
+       [ -d "${EPREFIX}"/var/lib/${PN} ] && my_is_new="no"
+       enewgroup ${PN}
+       enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+       if [ -d "${EPREFIX}"/var/lib/${PN} ] && [ "${my_is_new}" == "yes" ] ; then
+               # created by above enewuser command w/ wrong group and permissions
+               chown ${PN}:${PN} "${EPREFIX}"/var/lib/${PN} || die
+               chmod 0750 "${EPREFIX}"/var/lib/${PN} || die
+               # if user already exists, but /var/lib/minidlna is missing
+               # rely on ${D}/var/lib/minidlna created in src_install
+       fi
+
+       linux-info_pkg_setup
+}
+
+src_prepare() {
+       sed -e "/log_dir/s:/var/log:/var/log/${PN}:" \
+               -e "/db_dir/s:/var/cache/:/var/lib/:" \
+               -i ${PN}.conf || die
+
+       epatch "${WORKDIR}"/${PN}-gentoo-artwork.patch
+
+       epatch_user
+}
+
+src_configure() {
+       econf \
+               --disable-silent-rules \
+               --with-db-path=/var/lib/${PN} \
+               --with-log-path=/var/log/${PN} \
+               --enable-tivo \
+               $(use_enable netgear) \
+               $(use_enable readynas)
+}
+
+src_install() {
+       default
+
+       #bug 536532
+       dosym /usr/sbin/${PN}d /usr/bin/${PN}
+
+       insinto /etc
+       doins ${PN}.conf
+
+       newconfd "${FILESDIR}"/${PN}-1.0.25.confd ${PN}
+       newinitd "${FILESDIR}"/${PN}-1.1.2.initd ${PN}
+       systemd_newunit "${FILESDIR}"/${PN}-1.1.2.service ${PN}.service
+       echo "d /run/${PN} 0755 ${PN} ${PN} -" > "${T}"/${PN}.conf
+       systemd_dotmpfilesd "${T}"/${PN}.conf
+
+       dodir /var/{lib,log}/${PN}
+       fowners ${PN}:${PN} /var/{lib,log}/${PN}
+       fperms 0750 /var/{lib,log}/${PN}
+
+       dodoc AUTHORS NEWS README TODO
+       doman ${PN}d.8 ${PN}.conf.5
+}
+
+pkg_postinst() {
+       elog "minidlna now runs as minidlna:minidlna (bug 426726),"
+       elog "logfile is moved to /var/log/minidlna/minidlna.log,"
+       elog "cache is moved to /var/lib/minidlna."
+       elog "Please edit /etc/conf.d/${PN} and file ownerships to suit your needs."
+}