dev-db/mysql-init-scripts: Use tmpfiles eclass during install
authorBrian Evans <grknight@gentoo.org>
Mon, 27 Aug 2018 17:40:40 +0000 (13:40 -0400)
committerBrian Evans <grknight@gentoo.org>
Mon, 27 Aug 2018 17:40:40 +0000 (13:40 -0400)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-db/mysql-init-scripts/mysql-init-scripts-2.2-r3.ebuild

index 8fa8c8341de87027991fb4f56bb656a7877053d7..d0a1278895f8c1d6df7b213511ad253f00f3f513 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit systemd s6
+inherit systemd s6 tmpfiles
 
 DESCRIPTION="Gentoo MySQL init scripts."
 HOMEPAGE="https://www.gentoo.org/"
@@ -44,13 +44,14 @@ src_install() {
        doexe "${FILESDIR}"/mysqld-wait-ready
        systemd_newunit "${FILESDIR}/mysqld-v2.service" "mysqld.service"
        systemd_newunit "${FILESDIR}/mysqld_at-v2.service" "mysqld@.service"
-       systemd_dotmpfilesd "${FILESDIR}/mysql.conf"
+       dotmpfiles "${FILESDIR}/mysql.conf"
 
        insinto /etc/logrotate.d
        newins "${FILESDIR}/logrotate.mysql" "mysql"
 }
 
 pkg_postinst() {
+       tmpfiles_process mysql.conf
        if use amd64 || use x86 ; then
                elog ""
                elog "To use the mysql-s6 script, you need to install the optional sys-apps/s6 package."