sys-libs/glibc: drop telinit call from pkg_*(), bug #642784
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 21 Aug 2019 22:34:28 +0000 (23:34 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 21 Aug 2019 22:35:21 +0000 (23:35 +0100)
Rely on sysvinit re-execution on shutdown (bug #642858)
instead of relying on glibc's pkg_*() phases.

Reported-by: Mike Gilbert
Bug: https://bugs.gentoo.org/642784
Package-Manager: Portage-2.3.72, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/glibc/glibc-2.30.ebuild
sys-libs/glibc/glibc-9999.ebuild

index eafa9c84edb39144e730ec03a278245f08572a04..743f14c253d428848bf03b4963e3a358356ff95c 100644 (file)
@@ -1462,10 +1462,6 @@ pkg_postinst() {
        fi
 
        if ! is_crosscompile && [[ ${ROOT} == "/" ]] ; then
-               # Reload init ... if in a chroot or a diff init package, ignore
-               # errors from this step #253697
-               /sbin/telinit U 2>/dev/null
-
                use compile-locales || run_locale_gen "${EROOT}"
        fi
 
index e1955052ee365224154f99c41180ef412cce9c66..1075f02be79fde43534a05e6e4e9eaac3d9e18ca 100644 (file)
@@ -1449,10 +1449,6 @@ pkg_postinst() {
        fi
 
        if ! is_crosscompile && [[ -z ${ROOT} ]] ; then
-               # Reload init ... if in a chroot or a diff init package, ignore
-               # errors from this step #253697
-               /sbin/telinit U 2>/dev/null
-
                use compile-locales || run_locale_gen "${EROOT}/"
        fi