games-simulation/slime-rancher: New package
authorJames Le Cuirot <chewi@gentoo.org>
Wed, 1 Apr 2020 21:19:54 +0000 (22:19 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Wed, 1 Apr 2020 21:19:54 +0000 (22:19 +0100)
Package-Manager: Portage-2.3.96, Repoman-2.3.20
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-simulation/slime-rancher/Manifest [new file with mode: 0644]
games-simulation/slime-rancher/metadata.xml [new file with mode: 0644]
games-simulation/slime-rancher/slime-rancher-1.4.1c_p34605.ebuild [new file with mode: 0644]

diff --git a/games-simulation/slime-rancher/Manifest b/games-simulation/slime-rancher/Manifest
new file mode 100644 (file)
index 0000000..07b70c9
--- /dev/null
@@ -0,0 +1 @@
+DIST slime_rancher_1_4_1c_34605.sh 637631767 BLAKE2B e3742178acfb9b80429117a37e8c7ec226345fb20b762ef80ca7ff7d58bcde039a199db5f352e78ce6935b6b261924780f54c84dd706a8031b427c9bd52de2a7 SHA512 c9124a7685c12dab942cde3e4b7e4140156c9d1551043d450c0c2f2eb02d1db61b99f22803b1058634abff86e783c889badf5834f0c2f7048a97dc168c962908
diff --git a/games-simulation/slime-rancher/metadata.xml b/games-simulation/slime-rancher/metadata.xml
new file mode 100644 (file)
index 0000000..26079e6
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/games-simulation/slime-rancher/slime-rancher-1.4.1c_p34605.ebuild b/games-simulation/slime-rancher/slime-rancher-1.4.1c_p34605.ebuild
new file mode 100644 (file)
index 0000000..f69d7ad
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop unpacker xdg
+
+MY_PN="SlimeRancher"
+MY_P="${P//[-.]/_}"
+MY_P="${MY_P//_p/_}"
+
+DESCRIPTION="Cute game where you cultivate slimes on a distant planet"
+HOMEPAGE="http://www.slimerancher.com/"
+SRC_URI="${MY_P}.sh"
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+       sys-libs/glibc
+       virtual/opengl
+"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/data/noarch/game"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+       einfo "Please buy and download ${SRC_URI} from:"
+       einfo "  https://www.gog.com/game/${PN//-/_}"
+       einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+       unpack_zip ${A}
+}
+
+src_prepare() {
+       default
+
+       # Some Unity games have a GUI launcher but this one doesn't use it.
+       rm ${MY_PN}_Data/Plugins/x86_64/ScreenSelector.so || die
+}
+
+src_install() {
+       exeinto "${DIR}"
+       newexe ${MY_PN}.x86_64 ${MY_PN}
+       make_wrapper ${PN} "${DIR}"/${MY_PN}
+
+       insinto "${DIR}"
+       doins -r ${MY_PN}_Data/
+
+       newicon -s 128 ${MY_PN}_Data/Resources/UnityPlayer.png ${PN}.png
+       make_desktop_entry ${PN} "Slime Rancher"
+}