dev-libs/tvision: Version bump to 2.2.1.4
authorBernd Waibel <waebbl@gmail.com>
Sat, 25 Nov 2017 14:04:50 +0000 (15:04 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 29 Nov 2017 23:19:20 +0000 (00:19 +0100)
Copied over from release 2.1.0_pre2-r4
Add some USE flags: X, debug, gpm
Update metadata.xml: Add maintainer, longdescription, use

Application to proxy maintaining this package.

Closes: https://bugs.gentoo.org/638794
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Closes: https://github.com/gentoo/gentoo/pull/6295

dev-libs/tvision/Manifest
dev-libs/tvision/files/tvision-2.2.1.4-build-system.patch [new file with mode: 0644]
dev-libs/tvision/files/tvision-2.2.1.4-fix-dot-INC.patch [new file with mode: 0644]
dev-libs/tvision/files/tvision-2.2.1.4-flags.patch [new file with mode: 0644]
dev-libs/tvision/files/tvision-2.2.1.4-gcc6.patch [new file with mode: 0644]
dev-libs/tvision/files/tvision-2.2.1.4-ldconfig.patch [new file with mode: 0644]
dev-libs/tvision/metadata.xml
dev-libs/tvision/tvision-2.2.1.4.ebuild [new file with mode: 0644]

index e976d4ba28aec3ef967db02e7274575b848a8b06..c74c34504d38573bd6bbc002244eef711cffda85 100644 (file)
@@ -1 +1,2 @@
-DIST rhtvision_2.1.0-2.tar.gz 1590449 SHA256 fef19d839069dea2cd5459f24a190883a3b2b600a60d6f7823f456d8e6889412 SHA512 0593cd2eee9490d5cd6e79a6b8f4c0b384f78e5bb24b0728876fb9df482a43ee97c141d89127254210b4e012970327adfc5c8815d7c3c580a6d54a09291d42a1 WHIRLPOOL 5ce2e0bd7eb161aaef520a3bfafde7146784ac5a9d528ce73a51f502b23d790f42caeee5028508a8902615dfa31e295a988daef341f3fa3f6bb1c360b4b90d2b
+DIST rhtvision_2.1.0-2.tar.gz 1590449 BLAKE2B f5c31f997396f7b41b40089d3ebad8cdb5f24fce22f19defe3530d8a6cfcd728bf9cd3bcbb4e5d1d76c1fa3bc13c3b84f1147bd3c5aa07810077f5f159684eb0 SHA512 0593cd2eee9490d5cd6e79a6b8f4c0b384f78e5bb24b0728876fb9df482a43ee97c141d89127254210b4e012970327adfc5c8815d7c3c580a6d54a09291d42a1
+DIST rhtvision_2.2.1-4.tar.gz 1777675 BLAKE2B 04fee72d25c01825c8e21115bf16348e1f204371055490520d86a7eb6ad07d73c3d46f6046e11e01f7725b4fe8bd9eaf039ed72233f9141aaa19193635d6fe98 SHA512 bbbaab611fc7831eb339ddb612ef208a16e74f8e0961268e7e63f69c38cdfe45013d440861f3396aceabddf1a44e4cd65023b5b4238a39d55bbf133bde37dd8f
diff --git a/dev-libs/tvision/files/tvision-2.2.1.4-build-system.patch b/dev-libs/tvision/files/tvision-2.2.1.4-build-system.patch
new file mode 100644 (file)
index 0000000..d2c1316
--- /dev/null
@@ -0,0 +1,31 @@
+diff --git a/config.pl b/config.pl
+index 6a7a8b3..4664baa 100644
+--- a/config.pl
++++ b/config.pl
+@@ -1188,7 +1188,7 @@ sub GenerateMakefile
+     $rep.="\t\$(MAKE) -C intl\n";
+    }
+  $text=~s/\@target_rules\@/$rep/g;
+- $rep="intl-dummy:\n\t\$(MAKE) -C intl/dummy\n";
++ $rep="intl-dummy:\n\t\$(MAKE) prefix=\$(prefix) -C intl/dummy\n";
+  $rep.="\tcp intl/dummy/libtvfintl.a $makeDir\n";
+  $rep.="\tranlib $makeDir/libtvfintl.a\n" if $conf{'UseRanLib'};
+  $text=~s/\@intl_dummy_rule\@/$rep/g;
+@@ -1273,7 +1273,7 @@ sub GenerateMakefile
+    }
+  if ($internac)
+    {
+-    $rep.="\ninstall-internac:\n\t\$(MAKE) -C intl install\n";
++    $rep.="\ninstall-internac:\n\t\$(MAKE) prefix=\$(prefix) -C intl install\n";
+    }
+  $text=~s/\@install_rules\@/$rep/g;
+@@ -1293,7 +1293,7 @@ sub GenerateMakefile
+  $rep.="\trm -f intl/dummy/*.lo\n";
+  $rep.="\trm -f intl/dummy/*.a\n";
+  $rep.="\t-\$(MAKE) -C examples clean\n";
+- $rep.="\t-\$(MAKE) -C intl clean\n";
++ $rep.="\t-\$(MAKE) prefix=\$(prefix) -C intl clean\n";
+  $rep.="\trm -f configure.cache\n";
+  $rep.="\trm -f rhtv-config\$(EXE_EXT)\n";
+  $text=~s/\@clean\@/$rep/g;
diff --git a/dev-libs/tvision/files/tvision-2.2.1.4-fix-dot-INC.patch b/dev-libs/tvision/files/tvision-2.2.1.4-fix-dot-INC.patch
new file mode 100644 (file)
index 0000000..ee81c4f
--- /dev/null
@@ -0,0 +1,30 @@
+diff --git a/config.pl b/config.pl
+index caf9c2d..caf2ed3 100644
+--- a/config.pl
++++ b/config.pl
+@@ -5,8 +5,8 @@
+ # To specify the compilation flags define the CFLAGS environment variable.
+ #
+-require "miscperl.pl";
+-require "conflib.pl";
++require "./miscperl.pl";
++require "./conflib.pl";
+ # This optimization is giving problems and current PCs are quite fast to
+ # make a real difference.
+diff --git a/confignt.pl b/confignt.pl
+index e185f49..9ff7ae6 100644
+--- a/confignt.pl
++++ b/confignt.pl
+@@ -3,8 +3,8 @@
+ # see copyrigh file for details
+ #
+-require "miscperl.pl";
+-require "conflib.pl";
++require "./miscperl.pl";
++require "./conflib.pl";
+ SeeCommandLine();
diff --git a/dev-libs/tvision/files/tvision-2.2.1.4-flags.patch b/dev-libs/tvision/files/tvision-2.2.1.4-flags.patch
new file mode 100644 (file)
index 0000000..832a0c7
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 722fb29..f4128dc 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -31,7 +31,7 @@ examples:
+       $(MAKE) -C examples
+ rhtv-config$(EXE_EXT): rhtv-config.c include/tv/configtv.h
+-      @GCC@ -o rhtv-config$(EXE_EXT) -Iinclude rhtv-config.c
++      @GCC@ -o rhtv-config$(EXE_EXT) $(CFLAGS) $(LDFLAGS) -Iinclude rhtv-config.c
+ install-headers:
+       @install_headers@
diff --git a/dev-libs/tvision/files/tvision-2.2.1.4-gcc6.patch b/dev-libs/tvision/files/tvision-2.2.1.4-gcc6.patch
new file mode 100644 (file)
index 0000000..e882e85
--- /dev/null
@@ -0,0 +1,45 @@
+diff --git a/classes/tdesktop.cc b/classes/tdesktop.cc
+index 38f1be4..f8f44f0 100644
+--- a/classes/tdesktop.cc
++++ b/classes/tdesktop.cc
+@@ -26,6 +26,10 @@ Modified cursor behavior while desktop locked by Salvador E. Tropea (SET)
+ #define Uses_TVCodePage
+ #include <tv.h>
++#include <cmath>
++
++using std::abs;
++
+ TDeskInit::TDeskInit( TBackground *(*cBackground)( TRect ) ) :
+     createBackground( cBackground )
+ {
+diff --git a/classes/tdisplay.cc b/classes/tdisplay.cc
+index 9225d48..ee5eca8 100644
+--- a/classes/tdisplay.cc
++++ b/classes/tdisplay.cc
+@@ -22,6 +22,10 @@ same used in original Turbo Vision for compatibility purposes.
+ #define Uses_TVCodePage
+ #include <tv.h>
++#include <cmath>
++
++using std::abs;
++
+ // Remove me please!
+ int TDisplay::dual_display=0;
+diff --git a/classes/x11/x11src.cc b/classes/x11/x11src.cc
+index 538457e..10f9911 100644
+--- a/classes/x11/x11src.cc
++++ b/classes/x11/x11src.cc
+@@ -98,6 +98,10 @@
+  #define TIMER_ALARM SIGALRM
+ #endif
++#include <cmath>
++
++using std::abs;
++
+ const unsigned foWmin=5, foHmin=7, foWmax=20, foHmax=32;
+ const int cursorDelay=300000;
diff --git a/dev-libs/tvision/files/tvision-2.2.1.4-ldconfig.patch b/dev-libs/tvision/files/tvision-2.2.1.4-ldconfig.patch
new file mode 100644 (file)
index 0000000..f253eee
--- /dev/null
@@ -0,0 +1,17 @@
+diff --git a/config.pl b/config.pl
+index caf2ed3..6a7a8b3 100644
+--- a/config.pl
++++ b/config.pl
+@@ -1270,12 +1270,6 @@ sub GenerateMakefile
+     $rep.="\t".GenInstallFiles('0644',"$makeDir/$ver",'$(libdir)');
+     $stripDebug=($OSf eq 'Darwin') ? '-S' : '--strip-debug';
+     $rep.="\tstrip $stripDebug \$(libdir)/$ver\n" unless $conf{'debugInfo'} eq 'yes';
+-    # FreeBSD: merge data from libdir.
+-    # Darwin: doesn't have ldconfig.
+-    if ($OSf ne 'Darwin')
+-      {
+-       $rep.=($OSf eq 'FreeBSD') ? "\t-ldconfig -m \$(libdir)\n" : "\t-ldconfig\n";
+-      }
+    }
+  if ($internac)
+    {
index ae4bd97fa26b716da62a55a9ecc27fc83a482c8e..8fc9090f78d2fedcc18ccafb9280791887b30927 100644 (file)
@@ -1,7 +1,22 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>waebbl@gmail.com</email>
+               <name>Bernd Waibel</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription>
+               Text User Interface (TUI) that implements the well known CUA widgets.
+       </longdescription>
+       <use>
+               <flag restrict="&gt;dev-libs/tvision-2.2.1-r4" name="gpm">
+                       Support text mode mouse through <pkg>sys-libs/gpm</pkg>
+               </flag>
+       </use>
        <upstream>
                <remote-id type="sourceforge">tvision</remote-id>
        </upstream>
diff --git a/dev-libs/tvision/tvision-2.2.1.4.ebuild b/dev-libs/tvision/tvision-2.2.1.4.ebuild
new file mode 100644 (file)
index 0000000..0e8e0a5
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Text User Interface that implements the well known CUA widgets"
+HOMEPAGE="http://tvision.sourceforge.net/"
+MY_PVR=${PVR:0:5}-${PVR:6}
+SRC_URI="mirror://sourceforge/tvision/rhtvision_${MY_PVR}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+X debug gpm"
+
+DOCS=( readme.txt THANKS TODO )
+HTML_DOCS=( www-site/. )
+
+S=${WORKDIR}/${PN}
+
+# installed lib links to those
+RDEPEND="
+       dev-libs/libbsd
+       sys-apps/util-linux
+       sys-libs/ncurses:0=
+       gpm? ( sys-libs/gpm )
+       X? (
+               x11-libs/libICE
+               x11-libs/libSM
+               x11-libs/libX11
+               x11-libs/libXau
+               x11-libs/libXdmcp
+               x11-libs/libXext
+               x11-libs/libXmu
+               x11-libs/libXt
+               x11-libs/libxcb
+       )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}/${P}-fix-dot-INC.patch"
+       "${FILESDIR}/${P}-ldconfig.patch"
+       "${FILESDIR}/${P}-build-system.patch"
+       "${FILESDIR}/${P}-gcc6.patch"
+       "${FILESDIR}/${P}-flags.patch"
+)
+
+src_configure() {
+       # Note: Do not use econf here, this isn't an autoconf configure script,
+       # but a perl based script which simply calls config.pl
+       ./configure --fhs \
+               $(use_with debug debug) \
+               --without-static \
+       || die
+}
+
+src_install() {
+       emake DESTDIR="${D}" install \
+               prefix="\${DESTDIR}/${EPREFIX}/usr" \
+               libdir="\$(prefix)/$(get_libdir)"
+
+       einstalldocs
+       dosym rhtvision /usr/include/tvision
+
+       # remove CVS directory which gets copied over
+       rm -rf "${ED%/}/usr/share/doc/${P}/html/CVS" || die
+
+       # TODO: remove locales which are not needed, depending on current user
+       # locale settings. How?
+}