app-emulation/lxd: use get_golibdir_gopath for GOPATH
authorZac Medico <zmedico@gentoo.org>
Mon, 10 Aug 2015 21:06:10 +0000 (14:06 -0700)
committerZac Medico <zmedico@gentoo.org>
Mon, 10 Aug 2015 21:06:10 +0000 (14:06 -0700)
This is needed for compatibility with the latest go-crypto ebuild.

app-emulation/lxd/lxd-0.13.ebuild
app-emulation/lxd/lxd-0.14.ebuild

index d321646486349bf5226518eca29ea0d8362c323e..0485a2fab6f724b8e4bed523ec5b72f20664f2e8 100644 (file)
@@ -67,7 +67,7 @@ src_compile() {
        cd "${S}/src/${EGO_PN}"
 
        # Build binaries
-       GOPATH="${S}" emake
+       GOPATH="${S}:$(get_golibdir_gopath)" emake
 
        use nls && emake build-mo
 }
index 2324df5b0f11455f5cbf60eff49a91e0a85dc9ef..d5f20f000173c4c4db1197dee3604c118382219a 100644 (file)
@@ -68,7 +68,7 @@ src_compile() {
        cd "${S}/src/${EGO_PN}"
 
        # Build binaries
-       GOPATH="${S}" emake
+       GOPATH="${S}:$(get_golibdir_gopath)" emake
 
        use nls && emake build-mo
 }