dev-ada/gnatcoll-db: pkg_setup called both for python and Ada
authorTupone Alfredo <tupone@gentoo.org>
Sat, 21 Sep 2019 11:56:42 +0000 (13:56 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Sat, 21 Sep 2019 11:56:42 +0000 (13:56 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ada/gnatcoll-db/gnatcoll-db-2019.ebuild

index 6ea41d1f6302d9a43e9ff9421840669556dc42e9..0f1fd1c1c4d5489738f46cc9243c42d0831da4b3 100644 (file)
@@ -40,6 +40,11 @@ S="${WORKDIR}"/${PN}-${commitId}
 
 PATCHES=( "${FILESDIR}"/${PN}-2018-gentoo.patch )
 
+pkg_setup () {
+       python-single-r1_pkg_setup
+       ada_setup
+}
+
 src_compile() {
        build () {
                GPR_PROJECT_PATH="${S}/sql":"${S}/sqlite":"${S}/xref" \