app-emulation/docker-compose: Tests need pytest <4
authorSebastian Pipping <sping@gentoo.org>
Sun, 7 Jul 2019 14:17:34 +0000 (16:17 +0200)
committerSebastian Pipping <sping@gentoo.org>
Sun, 7 Jul 2019 14:22:47 +0000 (16:22 +0200)
Closes: https://bugs.gentoo.org/688688
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.67, Repoman-2.3.12

app-emulation/docker-compose/docker-compose-1.23.2-r1.ebuild
app-emulation/docker-compose/docker-compose-1.23.2.ebuild
app-emulation/docker-compose/docker-compose-1.24.0.ebuild
app-emulation/docker-compose/docker-compose-1.24.1.ebuild

index df1a0e87a6517daa96b18c4f1adfd99abc75506e..0e0b3b5585b157efc94f7a42c5c6d4f7b1239744 100644 (file)
@@ -33,7 +33,7 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
 
 DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}]
+       test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
 
 S="${WORKDIR}/compose-${PV}"
index 4028e926086575a1aaba0278dc6fc94d0b4a94fe..4b06e9a17e95a43e693abd0650cf3b9d5b51da02 100644 (file)
@@ -43,7 +43,7 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
 
 DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}]
+       test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
 
 S="${WORKDIR}/compose-${PV}"
index 27bb0bdfb34c902942ac1b5aa4ecd5ae82af0b47..4845028c559ddaccee8c7df3b85433fbbc3aa8c1 100644 (file)
@@ -34,7 +34,7 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
 
 DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}]
+       test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
 
 S="${WORKDIR}/compose-${PV}"
index 1efb5d463ed512846bc7db5e45ce330a09af09b7..0a65a87e67c31abbb80a68449879d326fc31cf63 100644 (file)
@@ -34,7 +34,7 @@ RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
 
 DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}]
+       test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
 
 S="${WORKDIR}/compose-${PV}"