Bump to 0.12.1 (minor bugfixes).
authorAlexandre Buisse <nattfodd@gentoo.org>
Mon, 9 Oct 2006 15:11:57 +0000 (15:11 +0000)
committerAlexandre Buisse <nattfodd@gentoo.org>
Mon, 9 Oct 2006 15:11:57 +0000 (15:11 +0000)
Package-Manager: portage-2.1.2_pre2-r6

media-sound/lltag/ChangeLog
media-sound/lltag/files/digest-lltag-0.12.1 [new file with mode: 0644]
media-sound/lltag/lltag-0.12.1.ebuild [new file with mode: 0644]

index e1b9f984396f01875567b9fae6362c846586b59a..84a88df356eb3b6be404d0a0b2fe29efbba56fbe 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/lltag
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lltag/ChangeLog,v 1.7 2006/09/20 12:42:03 nattfodd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lltag/ChangeLog,v 1.8 2006/10/09 15:11:57 nattfodd Exp $
+
+*lltag-0.12.1 (09 Oct 2006)
+
+  09 Oct 2006; Alexandre Buisse <nattfodd@gentoo.org> -lltag-0.12.ebuild,
+  +lltag-0.12.1.ebuild:
+  Bump to 0.12.1 (minor bugfixes).
 
 *lltag-0.12 (20 Sep 2006)
 
diff --git a/media-sound/lltag/files/digest-lltag-0.12.1 b/media-sound/lltag/files/digest-lltag-0.12.1
new file mode 100644 (file)
index 0000000..fcd45ed
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 72c0e92f1a267f6eb2c6c7c4b714b455 lltag-0.12.1.tar.bz2 35699
+RMD160 f5010cda64aa67a0aaf3bbff10d89bf308a4f283 lltag-0.12.1.tar.bz2 35699
+SHA256 1b3beb3897617689ace3d26bdeda74198eada50ae4d5ff8a6c18d7c8d0879d0a lltag-0.12.1.tar.bz2 35699
diff --git a/media-sound/lltag/lltag-0.12.1.ebuild b/media-sound/lltag/lltag-0.12.1.ebuild
new file mode 100644 (file)
index 0000000..a353c9e
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lltag/lltag-0.12.1.ebuild,v 1.1 2006/10/09 15:11:57 nattfodd Exp $
+
+inherit perl-module
+
+DESCRIPTION="Automatic command-line mp3/ogg/flac file tagger and renamer"
+HOMEPAGE="http://home.gna.org/lltag"
+SRC_URI="http://download.gna.org/lltag/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mp3 ogg flac readline"
+
+RDEPEND="dev-lang/perl
+       mp3? ( media-sound/mp3info )
+       ogg? ( media-sound/vorbis-tools )
+       flac? ( media-libs/flac )
+       readline? ( dev-perl/Term-ReadLine-Perl )"
+
+src_compile() {
+       make PREFIX=/usr SYSCONFDIR=/etc MANDIR=/usr/share/man \
+       PERL_INSTALLDIRS=vendor || die "Failed to compile"
+}
+
+src_install() {
+       make DESTDIR="${D}/" PREFIX=/usr SYSCONFDIR=/etc MANDIR=/usr/share/man \
+       PERL_INSTALLDIRS=vendor install || die "Failed to install"
+       fixlocalpod
+       dodoc Changes
+       dohtml doc/*.html
+}