gnome-extra/gnome-shell-extensions: Version bump, uses adwaita-icon-theme icons inste...
authorPacho Ramos <pacho@gentoo.org>
Sun, 10 Jan 2016 18:07:29 +0000 (19:07 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 10 Jan 2016 18:07:29 +0000 (19:07 +0100)
Package-Manager: portage-2.2.26

gnome-extra/gnome-shell-extensions/Manifest
gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.18.3.ebuild [new file with mode: 0644]

index e22bb55a8c650f6d306450892d68c69dabd6b0f2..ad9403be04b2839ecaac79dd49937d87751545ad 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnome-shell-extensions-3.16.2.tar.xz 231292 SHA256 0dca1677ec9401dd7c1a7261164b7f4cc94d52207637cf9e8e350bb9f6d0e9bf SHA512 f7f2bd9fe0ea2e9e14b7163c30fcf2cd93698f43de6ebc4daf3a655293db438c24d12972ceda2bf95def5ed15891c9f347c8bca404357e1e0ad131ab00cf50dd WHIRLPOOL 216d35ec3a200e9c3ed67ff0912b844394b12e764a1170beaf21162feeec7b7bb4cc1ddfe9efcd3ddff9bd4fc4224ff408bdeaf262b700323507fff08fa47a31
 DIST gnome-shell-extensions-3.18.2.tar.xz 233440 SHA256 cc514ffc896ed8c04853a89cb8e97058f9d5518313becf7c92aea5210b8adf61 SHA512 c24438495f8d79d21684b9c2d0d1eb753ed8d9ca99da34d6eb07007fe599aedfb1e0c54f55bddb9a76aa4eebfe7ee9017fdf4bcd97394a64eb68c68257ba7a2d WHIRLPOOL 544a70e24060c9601d465df53ce12ca0a0dadad95b351a59b38d3192628861b83f073aceb2ca1b6b669ca4f803aa6cc9dd5bab8988413cad05a381e783d4916c
+DIST gnome-shell-extensions-3.18.3.tar.xz 233480 SHA256 2bb3726decf14a31ae35755c049d8f03425231857c42ed27f01854af755ec035 SHA512 186ec469187b53a4eea0a5f29555265a2080c85405c83af8d10dd6be21f41c260e276f0c7579af48cb6cec86fc8deab6e44cf3861dcc24beb3efc5a44d7f3fa7 WHIRLPOOL 6be33c7bea752079d8c991ed716bd2323ee87fdc66811c45d757cd20cab4e133f61036226018439bd719fdf46f457fac0b53ab24d205c321b215ab1ae88c188b
diff --git a/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.18.3.ebuild b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.18.3.ebuild
new file mode 100644 (file)
index 0000000..727cb89
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="JavaScript extensions for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.26:2
+       >=gnome-base/libgtop-2.28.3[introspection]
+       >=app-eselect/eselect-gnome-shell-extensions-20111211
+"
+RDEPEND="${COMMON_DEPEND}
+       >=dev-libs/gjs-1.29
+       dev-libs/gobject-introspection:=
+       dev-libs/atk[introspection]
+       gnome-base/gnome-menus:3[introspection]
+       >=gnome-base/gnome-shell-3.14.2
+       media-libs/clutter:1.0[introspection]
+       net-libs/telepathy-glib[introspection]
+       x11-libs/gdk-pixbuf:2[introspection]
+       x11-libs/gtk+:3[introspection]
+       x11-libs/pango[introspection]
+       x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-util/intltool-0.50
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+# eautoreconf needs gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Installed extensions installed are initially disabled by default.
+To change the system default and enable some extensions, you can use
+# eselect gnome-shell-extensions
+
+Alternatively, to enable/disable extensions on a per-user basis,
+you can use the https://extensions.gnome.org/ web interface, the
+gnome-extra/gnome-tweak-tool GUI, or modify the org.gnome.shell
+enabled-extensions gsettings key from the command line or a script."
+
+src_configure() {
+       gnome2_src_configure --enable-extensions=all
+}
+
+src_install() {
+       gnome2_src_install
+
+       local example="example@gnome-shell-extensions.gcampax.github.com"
+       if use examples; then
+               mv "${ED}usr/share/gnome-shell/extensions/${example}" \
+                       "${ED}usr/share/doc/${PF}/" || die
+       else
+               rm -r "${ED}usr/share/gnome-shell/extensions/${example}" || die
+       fi
+
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+
+       ebegin "Updating list of installed extensions"
+       eselect gnome-shell-extensions update
+       eend $?
+
+       readme.gentoo_print_elog
+}