xfce-base/thunar: Bump to 1.8.3 (~arch branch)
authorMichał Górny <mgorny@gentoo.org>
Fri, 25 Jan 2019 13:19:05 +0000 (14:19 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 25 Jan 2019 13:19:46 +0000 (14:19 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/thunar/Manifest
xfce-base/thunar/thunar-1.8.3.ebuild [new file with mode: 0644]

index c055c01e25a2cde012d259406c68db6204547bcd..331cd2112a0b7e9a6b975a21add816691c58fd56 100644 (file)
@@ -4,3 +4,4 @@ DIST Thunar-1.6.16.tar.bz2 1977562 BLAKE2B efad6b45a64c5c80bff3d829207a1a0b45b4b
 DIST Thunar-1.7.2.tar.bz2 2236176 BLAKE2B e7ebcd8b74295539edfeed710cc25204691af3eaa1c84dcd9b56399f5af2220aabc9ce2736f03c7c1bfe9a61600c6acc4f659ba8d56e575f0e4679a644f1c459 SHA512 b98b72558c9a8872f89632820be816f2c2e7f7e07750cc62eace741794cde4aa4daf2f4ed7fd52a5b1e3c4e9965925a038a948124d32ed6d392db65b8780ccdb
 DIST Thunar-1.8.1.tar.bz2 2289891 BLAKE2B 79ccb1408bcacba7ed50536f0a8e622d2e251fedf4b0ffef425f1e0926dbaa93ccef0fa751c8362cb420eef013f9f442de3fe58d411558dd7b9cb5751d2e89f4 SHA512 89aa29af5e272d58c7de02ba1c96d7f0c32eed49cda9621ef863dd679712cc653f58e729e49b9dc3d1626c9b8ebe2b18a2307e00c7ea1d1d2b42fa71272aced7
 DIST Thunar-1.8.2.tar.bz2 2274521 BLAKE2B b5460a4bc5dd6547b8d620fd60a506899b4cfe6fdbadc46c9e7d259bed90ae5f98de2fa337762f8cbe5c7bdcb020ce3afd3d942763f0ea5aa84d1d9ceb47154f SHA512 c770fae8b6e5e0e42148ed2b9777afba5159783e5fc716eba1e0499b5390684f386eb575f1a608814bc118bbf05ede34c6737e28c06470c4d01717b579308ec9
+DIST Thunar-1.8.3.tar.bz2 2348196 BLAKE2B c89ad2a763b3aa6956e32777c7000fedbb8448704b11cfdb979e350a665b3ee3f43bc065af3fbd396c6810438ba5e49515204f40d68a2b2217fd4e18019140da SHA512 f584d4f8a474797bf422101c2eb21fe08e10c3ba0b842ac157b1016c49e164069181db9393c2c46c376e012bf0fd6ef693fd203175392368b5e30d5f44ee986f
diff --git a/xfce-base/thunar/thunar-1.8.3.ebuild b/xfce-base/thunar/thunar-1.8.3.ebuild
new file mode 100644 (file)
index 0000000..31c52fc
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils virtualx xdg-utils
+
+MY_P=${P^}
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre test +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+       >=dev-libs/glib-2.30:=
+       >=x11-libs/gdk-pixbuf-2.14:=
+       >=x11-libs/gtk+-3.22:3=
+       >=xfce-base/exo-0.12:=
+       >=xfce-base/libxfce4ui-4.12:=
+       >=xfce-base/libxfce4util-4.12:=
+       >=xfce-base/xfconf-4.12:=
+       exif? ( >=media-libs/libexif-0.6.19:= )
+       introspection? ( dev-libs/gobject-introspection:= )
+       libnotify? ( >=x11-libs/libnotify-0.7:= )
+       pcre? ( >=dev-libs/libpcre-6:= )
+       trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+       udisks? ( virtual/libgudev:= )"
+RDEPEND="${COMMON_DEPEND}
+       >=dev-util/desktop-file-utils-0.20-r1
+       x11-misc/shared-mime-info
+       trash-panel-plugin? ( ${GVFS_DEPEND} )
+       udisks? (
+               virtual/udev
+               ${GVFS_DEPEND}[udisks,udev]
+               )"
+DEPEND="${COMMON_DEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+
+src_configure() {
+       local myconf=(
+               $(use_enable introspection)
+               $(use_enable udisks gudev)
+               $(use_enable libnotify notifications)
+               $(use_enable exif)
+               $(use_enable pcre)
+               $(use_enable trash-panel-plugin tpa-plugin)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_test() {
+       virtx emake check
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}