dev-python/qdarkstyle: A dark style sheet for QtWidgets application
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Fri, 27 Dec 2019 13:11:27 +0000 (14:11 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 5 Jan 2020 10:09:44 +0000 (12:09 +0200)
New dependency of dev-python/spyder-4.0.0

Bug: https://bugs.gentoo.org/702458
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/qdarkstyle/Manifest [new file with mode: 0644]
dev-python/qdarkstyle/metadata.xml [new file with mode: 0644]
dev-python/qdarkstyle/qdarkstyle-2.7.ebuild [new file with mode: 0644]

diff --git a/dev-python/qdarkstyle/Manifest b/dev-python/qdarkstyle/Manifest
new file mode 100644 (file)
index 0000000..963ab61
--- /dev/null
@@ -0,0 +1 @@
+DIST qdarkstyle-2.7.tar.gz 9156490 BLAKE2B 6c1c21c728725f391802b30acb6365dbd073328158fb3a60b4e2b5bb846337149c166ab447b1e84a404b01b4bc41e1292fff974b2a9756c6c42f4b40754c9a0b SHA512 6185cb85009d62a74021c3267039c6309757909903d67a1b67315877b84d4ffbc468f49cbe54ca4c7319710ea74652a3013e574698d2037cc4f2d83c9fb2b28e
diff --git a/dev-python/qdarkstyle/metadata.xml b/dev-python/qdarkstyle/metadata.xml
new file mode 100644 (file)
index 0000000..20ab941
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+       <maintainer type="person">
+               <email>andrewammerlaan@riseup.net</email>
+               <name>Andrew Ammerlaan</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/qdarkstyle/qdarkstyle-2.7.ebuild b/dev-python/qdarkstyle/qdarkstyle-2.7.ebuild
new file mode 100644 (file)
index 0000000..20c0c40
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit eutils distutils-r1
+
+MY_PN="QDarkStyleSheet"
+
+DESCRIPTION="A dark style sheet for QtWidgets application"
+HOMEPAGE="https://github.com/ColinDuquesnoy/QDarkStyleSheet"
+SRC_URI="https://github.com/ColinDuquesnoy/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples test doc"
+
+RDEPEND=">=dev-python/helpdev-0.6.2[${PYTHON_USEDEP}]
+       doc? ( dev-python/m2r[${PYTHON_USEDEP}] )
+       examples? ( >=dev-python/QtPy-1.7[${PYTHON_USEDEP}] )"
+
+DEPEND="test? ( dev-python/QtPy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_install_all() {
+       if use examples; then
+               insinto /usr/share/${PN}
+               doins -r example
+       fi
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+               optfeature "To use qdarkstyle.utils please install" dev-python/qtsass
+}