app-i18n/libskk: update to EAPI 6
authorAkinori Hattori <hattya@gentoo.org>
Sat, 5 Aug 2017 14:13:00 +0000 (23:13 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 5 Aug 2017 14:13:00 +0000 (23:13 +0900)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

app-i18n/libskk/libskk-1.0.1.ebuild

index 6794948533ea573015a3ae97c1794905e42e3015..77cf687debec1eb7fa5820829c573a2ffe8e3c23 100644 (file)
@@ -1,49 +1,47 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI="6"
 
-VALA_MIN_API_VERSION="0.14"
-
-inherit virtualx vala
+inherit ltprune vala virtualx
 
 DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
 HOMEPAGE="https://github.com/ueno/libskk"
-SRC_URI="https://www.bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz"
+SRC_URI="https://bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz"
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="nls +introspection static-libs"
+IUSE="+introspection nls static-libs"
 
-RDEPEND=">=dev-libs/glib-2.16
-       dev-libs/libgee:0
+RDEPEND="dev-libs/glib:2
        dev-libs/json-glib
-       introspection? ( >=dev-libs/gobject-introspection-0.10.8 )
+       dev-libs/libgee:0
+       introspection? ( dev-libs/gobject-introspection )
        nls? ( virtual/libintl )"
 DEPEND="${RDEPEND}
        $(vala_depend)
+       dev-util/intltool
        virtual/pkgconfig
-       nls? (
-               dev-util/intltool
-               sys-devel/gettext
-               )"
-# doc? ( >=dev-util/valadoc-0.3.1 )
+       nls? ( sys-devel/gettext )"
 
-DOCS="ChangeLog NEWS README"
+src_prepare() {
+       vala_src_prepare
+       default
+}
 
 src_configure() {
        econf \
+               $(use_enable introspection) \
                $(use_enable nls) \
-               $(use_enable static-libs static) \
-               $(use_enable introspection)
+               $(use_enable static-libs static)
 }
 
 src_test() {
-       Xemake check || die "emake check failed."
+       virtx emake check
 }
 
 src_install() {
        default
-       rm -f "${ED}"/usr/lib*/lib*.la
+       prune_libtool_files
 }