dev-perl/Class-Autouse: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Sat, 23 May 2020 12:07:18 +0000 (00:07 +1200)
committerKent Fredric <kentnl@gentoo.org>
Sat, 23 May 2020 12:07:18 +0000 (00:07 +1200)
- EAPI7
- Pad out deps more
- Replace "sed" with "patch"

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Class-Autouse/Class-Autouse-2.10.0-r3.ebuild [new file with mode: 0644]
dev-perl/Class-Autouse/files/Class-Autouse-2.01-no-dot-inc.patch [new file with mode: 0644]

diff --git a/dev-perl/Class-Autouse/Class-Autouse-2.10.0-r3.ebuild b/dev-perl/Class-Autouse/Class-Autouse-2.10.0-r3.ebuild
new file mode 100644 (file)
index 0000000..5d651e9
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=2.01
+inherit perl-module
+
+DESCRIPTION="Runtime aspect loading of one or more classes"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=virtual/perl-File-Spec-0.800.0
+       >=virtual/perl-Scalar-List-Utils-1.180.0
+"
+BDEPEND="${RDEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.620.0
+       test? (
+               >=virtual/perl-File-Temp-0.170.0
+               >=virtual/perl-Test-Simple-0.470.0
+       )
+"
+PATCHES=(
+       "${FILESDIR}/${PN}-2.01-no-dot-inc.patch"
+)
diff --git a/dev-perl/Class-Autouse/files/Class-Autouse-2.01-no-dot-inc.patch b/dev-perl/Class-Autouse/files/Class-Autouse-2.01-no-dot-inc.patch
new file mode 100644 (file)
index 0000000..4fa0ab2
--- /dev/null
@@ -0,0 +1,21 @@
+From 1527dbac07ae3b1ec157aed01ea568cea9f1f52e Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 24 May 2020 00:00:53 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 9a4a412..f17b280 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install::DSL 1.04;
+ all_from      lib/Class/Autouse.pm
+-- 
+2.26.2
+