app-emulation/wine-mono: Wine .NET replacement library
authorNP-Hardass <NP-Hardass@gentoo.org>
Mon, 10 Apr 2017 17:05:43 +0000 (13:05 -0400)
committerNP-Hardass <NP-Hardass@gentoo.org>
Mon, 10 Apr 2017 17:21:54 +0000 (13:21 -0400)
Imported from wine-a-holics overlay

Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-emulation/wine-mono/Manifest [new file with mode: 0644]
app-emulation/wine-mono/metadata.xml [new file with mode: 0644]
app-emulation/wine-mono/wine-mono-4.6.4.ebuild [new file with mode: 0644]
app-emulation/wine-mono/wine-mono-4.7.0.ebuild [new file with mode: 0644]

diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
new file mode 100644 (file)
index 0000000..d9d3027
--- /dev/null
@@ -0,0 +1,2 @@
+DIST wine-mono-4.6.4.msi 45592064 SHA256 91b7d58177b9a9355edf007dab94535471aebdddae12734ceb4a219d2ecc4152 SHA512 1d50df5d4d000998c74fbee79b8ffc691d88ee3b34db9fd7124e0df68d6f84768ece489ac8c3f5f3141c2073c8666b93ae23ca6cd652a6542a821df3d1b66b6d WHIRLPOOL 54b77eabdb357822a89f3ff0d318755d0bae60a4a1df44ad33e663138d3f874f2bd271368df86e350ecc96908e77e82cc9ff7eef6cd80e20998b5cfc068703df
+DIST wine-mono-4.7.0.msi 64625152 SHA256 7698474dd9cb9eb80796b5812dff37386ba97b78b21ca23b20079ca5ad6ca5a1 SHA512 07cd2b26f3bfe6fc796a126b83e9c0aa655d3e8152af536ae2e8ae419013742706ddae6f93cc2341c94a2f3b8ae7d1b27d12f891d371928189291428f9ed877c WHIRLPOOL 9cdc9e4f680b0c7b6e46938a88c665f7702472c524521135ada7791e31c36a8ecbe95ed8720e2d67b53aa65c16e87c0fb85b654059ce0e146d401f99bcd5f0df
diff --git a/app-emulation/wine-mono/metadata.xml b/app-emulation/wine-mono/metadata.xml
new file mode 100644 (file)
index 0000000..1b77b64
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>wine@gentoo.org</email>
+               <name>Wine</name>
+       </maintainer>
+       <longdescription>
+               Wine Mono is a package containing Mono and other projects, intended as a replacement for the .NET runtime and class libraries in Wine. It works in conjunction with Wine's builtin mscoree.dll, and it is not intended to be useful for any other purpose.
+       </longdescription>
+       <upstream>
+               <remote-id type="github">makewokherd/wine-mono</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/app-emulation/wine-mono/wine-mono-4.6.4.ebuild b/app-emulation/wine-mono/wine-mono-4.6.4.ebuild
new file mode 100644 (file)
index 0000000..2479dca
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="https://dl.winehq.org/wine/${PN}/${PV}/${P}.msi"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+       insinto /usr/share/wine/mono
+       doins "${DISTDIR}/${P}.msi"
+}
diff --git a/app-emulation/wine-mono/wine-mono-4.7.0.ebuild b/app-emulation/wine-mono/wine-mono-4.7.0.ebuild
new file mode 100644 (file)
index 0000000..2479dca
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="https://dl.winehq.org/wine/${PN}/${PV}/${P}.msi"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+       insinto /usr/share/wine/mono
+       doins "${DISTDIR}/${P}.msi"
+}