cleanup and cleanout
authorTristan Heaven <tristan@gentoo.org>
Thu, 23 Nov 2006 22:59:13 +0000 (22:59 +0000)
committerTristan Heaven <tristan@gentoo.org>
Thu, 23 Nov 2006 22:59:13 +0000 (22:59 +0000)
Package-Manager: portage-2.1.2_rc2-r1

games-engines/zoom/files/digest-zoom-1.0.4a
games-engines/zoom/zoom-1.0.4a.ebuild

index 426f8b0d767fcde0eb569cac83d3e4cb75458a86..639746eab0bc5437bb059f1469b1b14212c8a3e5 100644 (file)
@@ -1 +1,3 @@
 MD5 5e07b403a98b77785e5b8052af169329 zoom-1.0.4a.tar.gz 1218580
+RMD160 79771fafc1cebc8e63e61d5c1b5e67061dce4cd8 zoom-1.0.4a.tar.gz 1218580
+SHA256 ded16904ba2acbe2efa1d2d5de09447e9260dae76ecc39bbc15e205c586bfc8b zoom-1.0.4a.tar.gz 1218580
index 79ce98a616f6cd8011ca5deb8bb83dbdef4c2931..6420da6b0b5efd4abf83abed80aa3e8c4a1f9f79 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/zoom/zoom-1.0.4a.ebuild,v 1.2 2006/01/29 00:11:39 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/zoom/zoom-1.0.4a.ebuild,v 1.3 2006/11/23 22:59:13 nyhm Exp $
 
 inherit flag-o-matic games
 
@@ -13,17 +13,13 @@ SLOT="0"
 KEYWORDS="ppc x86"
 IUSE=""
 
-RDEPEND="|| ( ( x11-libs/libSM
-                               x11-libs/libXft )
-                       virtual/x11 )
+RDEPEND="x11-libs/libSM
+       x11-libs/libXft
        media-libs/fontconfig
-       >=media-libs/t1lib-1.3.1
-       sys-libs/zlib
-       >=media-libs/libpng-1.2.4"
+       >=media-libs/t1lib-5
+       media-libs/libpng"
 DEPEND="${RDEPEND}
-       >=sys-devel/bison-1.34
-       dev-lang/perl
-       || ( x11-proto/xextproto virtual/x11 )"
+       x11-proto/xextproto"
 
 src_compile() {
        filter-flags -ffast-math
@@ -32,7 +28,7 @@ src_compile() {
 }
 
 src_install() {
-       make DESTDIR="${D}" install || die "make install failed"
+       emake DESTDIR="${D}" install || die "emake install failed"
        dodoc AUTHORS ChangeLog NEWS README THANKS TODO
        dohtml -r manual
        prepgamesdirs