app-office/grisbi: version bump 1.0.2
authorAmy Liffey <amynka@gentoo.org>
Thu, 18 Jan 2018 19:53:00 +0000 (20:53 +0100)
committerAmy Liffey <amynka@gentoo.org>
Thu, 18 Jan 2018 19:53:56 +0000 (20:53 +0100)
Submitted-by: Guillaume Castagnino <casta@xwing.info>
Closes: https://bugs.gentoo.org/643900

Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-office/grisbi/Manifest
app-office/grisbi/grisbi-1.0.2.ebuild [new file with mode: 0644]

index 456591fe19a4efa151a256702337b4bd2c6bd103..aff096d0d382e1c244a449b11f758cb7013512ea 100644 (file)
@@ -1 +1,2 @@
 DIST grisbi-1.0.0.tar.bz2 6933736 BLAKE2B daf2fac96452f6293e46c969a8b714cdc52f496506c5e61e341ded392b945118b817f42c43094b10b3e78a0f3fda18c9a2732931e0c6bb457064f51641492db6 SHA512 ec99f78cc4e6a7d3501bb40914491fc7a539c337e27f3360d84bcaff05bfa06dcd949f52177a7d2661cbc785ea9b27d3587cd4858363dc08a8daffac1015d77a
+DIST grisbi-1.0.2.tar.bz2 6956892 BLAKE2B dde75fbae341fc03226083567ff4731457abc7079ace92956c9e8b35ba4140dba32dc67ebe3b2a4826750229dbcd09da0f2eaf1f18c8783238d3fee274c46be9 SHA512 5988d362db8e94f135af34de1acfd7222ceeca11d229ffca533ca75c75c8054dda121bc45979106ee8f4ed2ac0660ba7836dfd053478fdbe4a2984cb94be3cf8
diff --git a/app-office/grisbi/grisbi-1.0.2.ebuild b/app-office/grisbi/grisbi-1.0.2.ebuild
new file mode 100644 (file)
index 0000000..392f5fb
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org"
+SRC_URI="mirror://sourceforge/grisbi/grisbi%20stable/1.0.x/${P}.tar.bz2"
+IUSE="libressl nls ofx ssl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+       dev-libs/libxml2:2
+       >=dev-libs/glib-2.18.0:2
+       >=x11-libs/gtk+-2.12.0:2
+       x11-misc/xdg-utils
+       ssl? (
+               libressl? ( dev-libs/libressl:0= )
+               !libressl? ( >=dev-libs/openssl-0.9.5:0= ) )
+       ofx? ( >=dev-libs/libofx-0.7.0 )
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+
+src_configure() {
+       gnome2_src_configure \
+               --with-libxml2 \
+               --without-cunit \
+               --disable-static \
+               $(use_with ssl openssl) \
+               $(use_with ofx) \
+               $(use_enable nls)
+}