sys-apps/attr: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 2 Jan 2020 11:54:19 +0000 (12:54 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 2 Jan 2020 11:54:19 +0000 (12:54 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/attr/Manifest
sys-apps/attr/attr-2.4.47-r2.ebuild [deleted file]

index c9dc8c8d3eac7541581961d158fe01a3af4fab62..b4c74752aa0cc3f6bcb1e4b9cc1236193158c573 100644 (file)
@@ -1,2 +1 @@
-DIST attr-2.4.47.src.tar.gz 343692 BLAKE2B af4d509f156cb2e693f0faebf1a6cfb4a27cbdd3fd7f8b436cc01419c905ff9ac36214ada2ca8269e49c2e276917b1178dcda97050cf25cecd65382f22bdf9bb SHA512 2a333f63655758298650cf8f89c175efdc0112dcc4013e8d023e2a9a69f177e4bcb1f1d10b6666d6f2027dca4dec0833d54749952ab153d28367e1a72e6e2831
 DIST attr-2.4.48.tar.gz 467840 BLAKE2B 8fa6a5013b927850868b6913d026f23f116b75da3925d5da5eea007e14f5d9e309f98290b7ffaa6c62f620ff8f3ec7bfb3a1fcb04f3c0c072fca5feacaf804c0 SHA512 75f870a0e6e19b8975f3fdceee786fbaff3eadaa9ab9af01996ffa8e50fe5b2bba6e4c22c44a6722d11b55feb9e89895d0151d6811c1d2b475ef4ed145f0c923
diff --git a/sys-apps/attr/attr-2.4.47-r2.ebuild b/sys-apps/attr/attr-2.4.47-r2.ebuild
deleted file mode 100644 (file)
index 62babe4..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils libtool toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="https://savannah.nongnu.org/projects/attr"
-SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="nls static-libs"
-
-DEPEND="nls? ( sys-devel/gettext )
-       sys-devel/autoconf"
-RDEPEND=""
-
-src_prepare() {
-       sed -i \
-               -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
-               -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
-               include/builddefs.in \
-               || die
-       strip-linguas -u po
-       elibtoolize #580792
-
-       multilib_copy_sources # https://savannah.nongnu.org/bugs/index.php?39736
-}
-
-multilib_src_configure() {
-       unset PLATFORM #184564
-       export OPTIMIZER=${CFLAGS}
-       export DEBUG=-DNDEBUG
-
-       econf \
-               $(use_enable nls gettext) \
-               --enable-shared $(use_enable static-libs static) \
-               --libexecdir="${EPREFIX}"/usr/$(get_libdir) \
-               --bindir="${EPREFIX}"/bin
-}
-
-multilib_src_compile() {
-       emake $(multilib_is_native_abi || echo TOOL_SUBDIRS=)
-}
-
-multilib_src_install() {
-       emake \
-               $(multilib_is_native_abi || echo TOOL_SUBDIRS=) \
-               DIST_ROOT="${D}" \
-               install install-lib install-dev
-
-       if multilib_is_native_abi; then
-               # we install attr into /bin, so we need the shared lib with it
-               gen_usr_ldscript -a attr
-               # the man-pages packages provides the man2 files
-               # note: man-pages are installed by TOOL_SUBDIRS
-               rm -r "${ED}"/usr/share/man/man2 "${ED}"/usr/share/man/man5/attr.5 || die
-       fi
-}
-
-multilib_src_install_all() {
-       use static-libs || prune_libtool_files --all
-       einstalldocs
-}