dev-lang/mmix: use shorter 'dodoc' form
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 9 Nov 2019 14:54:02 +0000 (14:54 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 9 Nov 2019 14:54:02 +0000 (14:54 +0000)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-lang/mmix/mmix-20160804-r1.ebuild
dev-lang/mmix/mmix-20160804.ebuild

index 3d8f806d1bb81eaab59a6808762e025663181318..65491269b4a12c3e16a32358627e32aa0d96cfca 100644 (file)
@@ -41,8 +41,5 @@ src_install() {
        dobin ${PN} ${PN}al m${PN} mmotype abstime
        dodoc README ${PN}.1
 
-       if use doc ; then
-               insinto /usr/share/doc/${PF}
-               doins *.ps
-       fi
+       use doc && dodoc *.ps
 }
index ec72856d158d7dc035444b768342de6c6eaad42b..95967668d8d0ee40a8e6df03ce349936b78c0ebb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -36,12 +36,9 @@ src_compile() {
        fi
 }
 
-src_install () {
+src_install() {
        dobin ${PN} ${PN}al m${PN} mmotype abstime
        dodoc README ${PN}.1
 
-       if use doc ; then
-               insinto /usr/share/doc/${PF}
-               doins *.ps
-       fi
+       use doc && dodoc *.ps
 }