dev-python/python-redmine: Enable py3.{7,8}, modernize
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 06:58:12 +0000 (08:58 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 10:16:52 +0000 (12:16 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-redmine/python-redmine-2.0.2.ebuild

index 004a759abd1ced625254fd0cf133ff0a8989aac5..403396ebdefe924900164c8ae7e8181ca80e6499 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -14,19 +14,10 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
 
-# This package bundles dev-python/requests, so setup.py won't check for
-# it. As a result, we don't need RDEPEND in DEPEND unconditionally.
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/coverage[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
+distutils_enable_tests nose
 
 python_prepare_all() {
        # Remove the bundled copy of dev-python/requests...
@@ -40,7 +31,3 @@ python_prepare_all() {
 
        distutils-r1_python_prepare_all
 }
-
-python_test() {
-       nosetests || die "tests failed under ${EPYTHON}"
-}