New upstream version. Removed old version
authorOlivier Fisette <ribosome@gentoo.org>
Tue, 12 Dec 2006 20:11:35 +0000 (20:11 +0000)
committerOlivier Fisette <ribosome@gentoo.org>
Tue, 12 Dec 2006 20:11:35 +0000 (20:11 +0000)
Package-Manager: portage-2.1.1-r2

sci-biology/prosite/ChangeLog
sci-biology/prosite/files/digest-prosite-20.1 [new file with mode: 0644]
sci-biology/prosite/prosite-20.1.ebuild [new file with mode: 0644]

index e3a5edcdf839dc631753da76c172e7cebe24508e..a3fa8706e60a84e9147694ee9b4db12ec12cb2a5 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sci-biology/prosite
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/ChangeLog,v 1.93 2006/12/10 18:57:37 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/ChangeLog,v 1.94 2006/12/12 20:11:35 ribosome Exp $
+
+*prosite-20.1 (12 Dec 2006)
+
+  12 Dec 2006; Olivier Fisette <ribosome@gentoo.org> -prosite-19.38.ebuild,
+  +prosite-20.1.ebuild:
+  New upstream version. Removed old version.
 
   10 Dec 2006; Olivier Fisette <ribosome@gentoo.org> -prosite-19.18.ebuild,
   -prosite-19.22.ebuild, -prosite-19.37.ebuild:
diff --git a/sci-biology/prosite/files/digest-prosite-20.1 b/sci-biology/prosite/files/digest-prosite-20.1
new file mode 100644 (file)
index 0000000..725a45e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 e8af17b8e04d3028a60e284f8e0da496 prosite-20.1.tar.bz2 4814695
+RMD160 f01d2dafe777f6aa8aa1af04f16ce0e7587e3f0e prosite-20.1.tar.bz2 4814695
+SHA256 a46163b10eeef64752e6c5e43ea0e02a0479c9700351e58d45fe889fafe6a377 prosite-20.1.tar.bz2 4814695
diff --git a/sci-biology/prosite/prosite-20.1.ebuild b/sci-biology/prosite/prosite-20.1.ebuild
new file mode 100644 (file)
index 0000000..f330761
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-20.1.ebuild,v 1.1 2006/12/12 20:11:35 ribosome Exp $
+
+DESCRIPTION="A protein families and domains database"
+LICENSE="swiss-prot"
+HOMEPAGE="http://ca.expasy.org/prosite"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="emboss? ( >=sci-biology/emboss-3.0.0 )"
+
+src_compile() {
+       if use emboss; then
+               mkdir PROSITE
+               echo
+               einfo "Indexing PROSITE for usage with EMBOSS."
+               EMBOSS_DATA="." prosextract -auto -prositedir "${S}" || die \
+                       "Indexing PROSITE failed."
+               echo
+       fi
+}
+
+src_install() {
+       if ! use minimal; then
+               insinto /usr/share/${PN}
+               doins *.{doc,dat,lis} || die "Installing raw database failed."
+       fi
+       dodoc *.txt || die "Documentation installation failed."
+       dohtml *.htm || die "HTML documentation installation failed."
+       insinto /usr/share/doc/${PF}
+       doins *.pdf || die "PDF documentation installation failed."
+       if use emboss; then
+               insinto /usr/share/EMBOSS/data/PROSITE
+               doins PROSITE/* || die "Installing EMBOSS data files failed."
+       fi
+}