sys-devel/libtool: Sync live ebuild
authorDavid Seifert <soap@gentoo.org>
Mon, 23 Dec 2019 23:02:51 +0000 (00:02 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 28 Dec 2019 15:19:21 +0000 (16:19 +0100)
Acked-by: Lars Wendler <polynomial-c@gentoo.org>
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-devel/libtool/libtool-9999.ebuild

index 96ef613cceeadedb4743e9c44d1b65771979e42f..a929635d35d7eedc8026c6313cec183fa2295c6d 100644 (file)
@@ -1,19 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 LIBTOOLIZE="true" #225559
 WANT_LIBTOOL="none"
-inherit autotools epunt-cxx multilib unpacker prefix
+inherit autotools prefix
 
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
-               http://git.savannah.gnu.org/r/${PN}.git"
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://git.savannah.gnu.org/git/libtool.git"
        inherit git-r3
 else
        SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
 fi
 
 DESCRIPTION="A shared library tool for developers"
@@ -24,14 +23,13 @@ SLOT="2"
 IUSE="vanilla"
 
 # Pull in libltdl directly until we convert packages to the new dep.
-RDEPEND="sys-devel/gnuconfig
-       >=sys-devel/autoconf-2.69
-       >=sys-devel/automake-1.13
-       dev-libs/libltdl:0
-       !<sys-apps/sandbox-2.10-r4"
-DEPEND="${RDEPEND}
-       app-arch/xz-utils"
-[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
+RDEPEND="
+       sys-devel/gnuconfig
+       >=sys-devel/autoconf-2.69:*
+       >=sys-devel/automake-1.13:*
+       dev-libs/libltdl:0"
+DEPEND="${RDEPEND}"
+[[ ${PV} == *9999 ]] && BDEPEND="sys-apps/help2man"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
@@ -40,27 +38,25 @@ PATCHES=(
        "${FILESDIR}"/${PN}-2.4.6-darwin-use-linux-version.patch
 )
 
-src_unpack() {
-       if [[ ${PV} == "9999" ]] ; then
-               git-r3_src_unpack
-       else
-               unpacker_src_unpack
-       fi
-}
-
 src_prepare() {
-       if [[ "${PV}" = 9999 ]] ; then
+       if [[ ${PV} == *9999 ]] ; then
                eapply "${FILESDIR}"/${PN}-2.4.6-pthread.patch #650876
                ./bootstrap || die
        else
                PATCHES+=(
-                       "${FILESDIR}"/${P}-pthread_bootstrapped.patch #650876
+                       "${FILESDIR}"/${PN}-2.4.6-pthread_bootstrapped.patch #650876
                )
        fi
 
-       use vanilla && return 0
+       # WARNING: File build-aux/ltmain.sh is read-only; trying to patch anyway
+       chmod +w build-aux/ltmain.sh || die
 
-       default
+       if use vanilla ; then
+               eapply_user
+               return 0
+       else
+               default
+       fi
 
        if use prefix ; then
                # seems that libtool has to know about EPREFIX a little bit
@@ -73,15 +69,15 @@ src_prepare() {
                eapply "${FILESDIR}"/${PN}-2.2.10-eprefix.patch
                eprefixify m4/libtool.m4
        fi
-       pushd libltdl >/dev/null
+
+       pushd libltdl >/dev/null || die
        AT_NOELIBTOOLIZE=yes eautoreconf
-       popd >/dev/null
+       popd >/dev/null || die
        AT_NOELIBTOOLIZE=yes eautoreconf
-       epunt_cxx
 
        # Make sure timestamps don't trigger a rebuild of man pages. #556512
-       if [[ ${PV} != "9999" ]] ; then
-               touch doc/*.1
+       if [[ ${PV} != *9999 ]] ; then
+               touch doc/*.1 || die
                export HELP2MAN=false
        fi
 }
@@ -96,15 +92,10 @@ src_configure() {
        # Do not bother hardcoding the full path to sed.  Just rely on $PATH. #574550
        export ac_cv_path_SED="$(basename "$(type -P sed)")"
 
-       local myconf
-       [[ ${CHOST} == *-darwin* ]] && myconf="--program-prefix=g"
+       [[ ${CHOST} == *-darwin* ]] && local myconf="--program-prefix=g"
        ECONF_SOURCE=${S} econf ${myconf} --disable-ltdl-install
 }
 
-src_test() {
-       emake check
-}
-
 src_install() {
        default