dev-python/cffi: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 10:21:53 +0000 (12:21 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 10:23:44 +0000 (12:23 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cffi/Manifest
dev-python/cffi/cffi-1.13.2.ebuild [deleted file]

index 92cabc666cfb8d385c76dc56e17dc44a476c3bff..380fea6a6ea3a74bbf32aaad81941502d4cd8695 100644 (file)
@@ -1,2 +1 @@
-DIST cffi-1.13.2.tar.gz 460243 BLAKE2B 74603f2b1bde068a955e94912488fd7d8914267ec2d0cbd8574f62376fc24ef16d85d59e9fee7f6015e6d242726ea25235788faddedc68deb56ae71e627d6322 SHA512 2c57d9c06c39e95498a54408dc39940427190f3c03e1b8f1a3584140db08a5775dd12e6e67b03093429c130af579d01519b0fc868b99ba7a530068ed22d38522
 DIST cffi-1.14.0.tar.gz 463065 BLAKE2B 4d1e8a92241db801848ef8bd05ea15a31c7f61ea426ce4da184aff00df786348d2c76de9dc48898c814478aed9750b665868df24ad39435062cd7e1c84163e52 SHA512 4c5451eeede1d48a8f4b40e25b845ad1863b8bf3bd39624e6c693c2800d89a13efedc4c43b37e317a035613bffc2e3fd5f7e583c46cb283cb5cb930356f86253
diff --git a/dev-python/cffi/cffi-1.13.2.ebuild b/dev-python/cffi/cffi-1.13.2.ebuild
deleted file mode 100644 (file)
index e603db8..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="virtual/libffi:="
-RDEPEND="${DEPEND}
-       dev-python/pycparser[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
-       virtual/pkgconfig
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx doc/source
-
-src_configure() {
-       tc-export PKG_CONFIG
-}
-
-python_test() {
-       "${EPYTHON}" -c "import _cffi_backend as backend" || die
-       pytest -x -vv \
-               --ignore testing/test_zintegration.py \
-               --ignore testing/embedding \
-               c/ testing/ \
-               || die "Testing failed with ${EPYTHON}"
-}