app-portage/unsymlink-lib: Bump to v15, with improved output
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Jun 2019 18:28:40 +0000 (20:28 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 7 Jun 2019 18:30:17 +0000 (20:30 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/unsymlink-lib/Manifest
app-portage/unsymlink-lib/unsymlink-lib-15.ebuild [new file with mode: 0644]

index 57e5fe378f7230eabc83208e308ad08e6ee7eef3..fd6ad6e09e5de4cd5c6c1b63e2f4cc3cfae2582a 100644 (file)
@@ -1,2 +1,3 @@
 DIST unsymlink-lib-13.tar.gz 8736 BLAKE2B 5b44112299232185f3f7a5d88057caa7e9161ca03a3e79bebd9dbf70a61ddde255d3a24679b9004cc572fedcfc24ffeb42693319e5dfa1f8371f8fed1408b15d SHA512 c87676b80259f2a20fde257e2b090380c3b04be1542a5a92832487327b8d1eb737059a6e6898f713fa378b792e23d2896280b94cb00d7961a0beba81cd6b3bd2
 DIST unsymlink-lib-14.tar.gz 10089 BLAKE2B 24252eb31a0a0fe83a260e8eee76d42c473d76dbebe4d2fd604d1ab663ea7439da4c03dd0b953efa30e0d74d654101b7a0264db1da50de826c5a5f4ae79f3ff0 SHA512 ab3ffcbc7cdcac98068a6e3c86e71cb472cff67aed1ddc570701ed6c34fa17e04d84a13bf5fb2696aeff0f8338b2464d1e06ce829ffc693011c51481ecba2be8
+DIST unsymlink-lib-15.tar.gz 10145 BLAKE2B 500b78a84cd555319952ce6420af012354952ebd83983db121f1a48ee34d5c2ce9a9f56ce635d6f77eb38058b79d42cf94d2e421414095c188949db523aacbe0 SHA512 37b8cc4eb7b787a1ccc97750df9fcd4516c2c4ac110c5191b4be3999b1eb994ee567e0f4387aaafe243a745efa61c0d48d78b7f9a4a58bb7f896ccd7bdce03a7
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-15.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-15.ebuild
new file mode 100644 (file)
index 0000000..90b56e6
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       sys-apps/portage[${PYTHON_USEDEP}]"
+
+src_test() {
+       # tests are docker-based
+       :
+}
+
+src_install() {
+       python_doscript unsymlink-lib
+       dodoc README
+}