games-board/pokerth: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 15:10:12 +0000 (16:10 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 16:04:42 +0000 (17:04 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/3597

games-board/pokerth/files/pokerth-1.1.1-underlinking.patch [deleted file]
games-board/pokerth/pokerth-1.1.1-r1.ebuild [deleted file]
games-board/pokerth/pokerth-1.1.1.ebuild [deleted file]

diff --git a/games-board/pokerth/files/pokerth-1.1.1-underlinking.patch b/games-board/pokerth/files/pokerth-1.1.1-underlinking.patch
deleted file mode 100644 (file)
index 397fb7d..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Thu Aug 16 22:25:12 UTC 2012
-Subject: build system
-
-fix compilation for linkers that don't permit underlinking
-reorder linker line to fix issues with as-needed
-
---- pokerth_server.pro
-+++ pokerth_server.pro
-@@ -114,8 +114,8 @@
- LIBS += -lpokerth_lib \
-       -lpokerth_db \
-       -lpokerth_protocol \
--      -lcurl \
--      -lircclient
-+      -lircclient \
-+      $$system(pkg-config --libs --static libcurl)
- win32 {
-       DEFINES += CURL_STATICLIB
diff --git a/games-board/pokerth/pokerth-1.1.1-r1.ebuild b/games-board/pokerth/pokerth-1.1.1-r1.ebuild
deleted file mode 100644 (file)
index 965e246..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit flag-o-matic eutils qmake-utils games
-
-MY_P="PokerTH-${PV}-src"
-DESCRIPTION="Texas Hold'em poker game"
-HOMEPAGE="http://www.pokerth.net/"
-SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
-
-LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="dedicated"
-
-RDEPEND="dev-db/sqlite:3
-       dev-libs/boost:=[threads(+)]
-       dev-libs/protobuf
-       dev-libs/libgcrypt:0
-       dev-libs/tinyxml[stl]
-       >=net-libs/libircclient-1.6-r2
-       >=net-misc/curl-7.16
-       dev-qt/qtcore:5
-       dev-qt/qtnetwork:5
-       virtual/gsasl
-       !dedicated? (
-               media-libs/libsdl:0
-               media-libs/sdl-mixer[mod,vorbis]
-               dev-qt/qtgui:5
-               dev-qt/qtwidgets:5
-       )"
-DEPEND="${RDEPEND}
-       !dedicated? ( dev-qt/qtsql:5 )
-       virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       if use dedicated ; then
-               sed -i -e 's/pokerth_game.pro//' pokerth.pro || die
-       fi
-
-       sed -i -e '/no_dead_strip_inits_and_terms/d' *pro || die
-
-       epatch "${FILESDIR}"/${P}-qt5.patch \
-               "${FILESDIR}/${P}-boost-1.60.patch"
-}
-
-src_configure() {
-       eqmake5 pokerth.pro
-}
-
-src_install() {
-       dogamesbin bin/pokerth_server
-       if ! use dedicated ; then
-               dogamesbin ${PN}
-               insinto "${GAMES_DATADIR}/${PN}"
-               doins -r data
-               domenu ${PN}.desktop
-               doicon ${PN}.png
-       fi
-       doman docs/pokerth.1
-       dodoc ChangeLog TODO docs/{gui_styling,server_setup}_howto.txt
-       prepgamesdirs
-}
diff --git a/games-board/pokerth/pokerth-1.1.1.ebuild b/games-board/pokerth/pokerth-1.1.1.ebuild
deleted file mode 100644 (file)
index d12b3d8..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit flag-o-matic eutils qt4-r2 games
-
-MY_P="PokerTH-${PV}-src"
-DESCRIPTION="Texas Hold'em poker game"
-HOMEPAGE="http://www.pokerth.net/"
-SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
-
-LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="dedicated"
-
-RDEPEND="dev-db/sqlite:3
-       dev-libs/boost:=[threads(+)]
-       dev-libs/protobuf
-       dev-libs/libgcrypt:0
-       dev-libs/tinyxml[stl]
-       amd64? ( net-libs/libircclient )
-       ppc? ( >=net-libs/libircclient-1.6-r2 )
-       x86? ( net-libs/libircclient )
-       >=net-misc/curl-7.16
-       dev-qt/qtcore:4
-       virtual/gsasl
-       !dedicated? (
-               media-libs/libsdl:0
-               media-libs/sdl-mixer[mod,vorbis]
-               dev-qt/qtgui:4
-       )"
-DEPEND="${RDEPEND}
-       !dedicated? ( dev-qt/qtsql:4 )
-       virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       if use dedicated ; then
-               sed -i \
-                       -e 's/pokerth_game.pro//' \
-                       pokerth.pro || die
-       fi
-
-       sed -i \
-               -e '/no_dead_strip_inits_and_terms/d' \
-               *pro || die
-
-       #epatch "${FILESDIR}"/${P}-underlinking.patch
-}
-
-src_configure() {
-       eqmake4
-}
-
-src_install() {
-       dogamesbin bin/pokerth_server
-       if ! use dedicated ; then
-               dogamesbin ${PN}
-               insinto "${GAMES_DATADIR}/${PN}"
-               doins -r data
-               domenu ${PN}.desktop
-               doicon ${PN}.png
-       fi
-       doman docs/pokerth.1
-       dodoc ChangeLog TODO docs/{gui_styling,server_setup}_howto.txt
-       prepgamesdirs
-}