dev-lang/perl: More TC love for nm/cpp/ranlib re bug #723734
authorKent Fredric <kentnl@gentoo.org>
Mon, 18 May 2020 13:15:12 +0000 (01:15 +1200)
committerKent Fredric <kentnl@gentoo.org>
Mon, 18 May 2020 13:18:45 +0000 (01:18 +1200)
commit10f82b45e3946956fec887a87ce4ceb6c11fc680
tree1291319bc612cb2bbfd0d2e54bfcba5253b26612
parentabb702d7a921d5848344ae2d6c2e86b8293a7de7
dev-lang/perl: More TC love for nm/cpp/ranlib re bug #723734

While this won't fix the warnings about hints/linux.sh, as that is
something too complex for me to trivially fix, it should mitigate the
warnings about nm and cpp, and additonally, guards against a possible
future where ranlib is also nuked and later tried to be used from
$Config{ranlib}

-r bump for compile propagation reasons, real delta:

--- a/dev-lang/perl/perl-5.30.2-r1.ebuild
+++ b/dev-lang/perl/perl-5.30.2-r2.ebuild
@@ -502,11 +502,16 @@ src_configure() {
        # allow fiddling via EXTRA_ECONF, bug 558070
        eval "local -a EXTRA_ECONF=(${EXTRA_ECONF})"

+       # setting -Dld= to tc-getLD breaks perl and all perl things
+       # https://github.com/Perl/perl5/issues/17791#issuecomment-630145202
        myconf \
                -Duseshrplib \
                -Darchname="${myarch}" \
                -Dcc="$(tc-getCC)" \
                -Dar="$(tc-getAR)" \
+               -Dnm="$(tc-getNM)" \
+               -Dcpp="$(tc-getCPP)" \
+               -Dranlib="$(tc-getRANLIB)" \
                -Doptimize="${CFLAGS}" \
                -Dldflags="${LDFLAGS}" \
                -Dprefix="${EPREFIX}"'/usr' \

Bug: https://bugs.gentoo.org/723734
Bug: https://github.com/Perl/perl5/issues/17791#issuecomment-630123559
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-lang/perl/perl-5.30.2-r2.ebuild [new file with mode: 0644]