x11-wm/compiz: Drop deprecated Plasma 4 support
[gentoo.git] / x11-wm / compiz / compiz-0.8.8-r3.ebuild
index 2b313d2745b5ce5231204a2adfe7f3d2aaadbb6c..7bf01e7e834efe03701f1ff8f7c04d721379005a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -13,7 +13,7 @@ SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
 LICENSE="GPL-2 LGPL-2.1 MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="+cairo dbus fuse gnome gconf gtk kde +svg"
+IUSE="+cairo dbus fuse gnome gconf gtk +svg"
 
 COMMONDEPEND="
        >=dev-libs/glib-2
@@ -51,7 +51,6 @@ COMMONDEPEND="
                >=x11-libs/libwnck-2.18.3:1
                x11-libs/pango
        )
-       kde? ( >=kde-base/kwin-4.2.0 )
        svg? (
                >=gnome-base/librsvg-2.14.0:2
                >=x11-libs/cairo-1.0
@@ -83,14 +82,6 @@ src_prepare() {
        if ! use gnome || ! use gconf; then
                epatch "${FILESDIR}"/${PN}-no-gconf.patch
        fi
-       if use kde; then
-               # patch for KDE 4.8 compatibility. Picked up from stuff overlay
-               has_version ">=kde-base/kwin-4.8" && epatch "${FILESDIR}"/${PN}-kde-4.8.patch
-               # patch for KDE 4.9 compatibility. Picked up from http://cgit.compiz.org
-               has_version ">=kde-base/kwin-4.9" && epatch "${FILESDIR}"/${PN}-kde-4.9.patch
-               # patch for KDE 4.10 compatibility. Picked up from stuff overlay
-               has_version ">=kde-base/kwin-4.10" && epatch "${FILESDIR}"/${PN}-kde-4.10.patch
-       fi
        eautoreconf
 }
 
@@ -118,7 +109,7 @@ src_configure() {
                $(use_enable gnome) \
                $(use_enable gnome metacity) \
                $(use_enable gtk) \
-               $(use_enable kde kde4) \
+               --disable-kde4 \
                --disable-kde \
                ${myconf}
 }