dev-python/flask-cors/flask-cors-9999.ebuild: Use local intersphinx
[wtk-overlay.git] / sci-misc / comedi-calibrate / comedi-calibrate-9999.ebuild
index 27a6c01bb1dec2721b1ad5144e490bdcf12967c1..28c3d6cf70f5f2115f96d6810b7cc9b8654d6aa7 100644 (file)
@@ -33,8 +33,27 @@ DEPEND="${RDEPEND}
 
 src_prepare()
 {
-       epatch "${FILESDIR}/${PN}-9999-comedi_soft_calibrate-data-destdir.patch"
        if [ "${PV}" == "9999" ] ; then
                eautoreconf
        fi
 }
+
+src_configure()
+{
+       # by default, Gentoo uses `"${EPREFIX}"/var/lib` for
+       # localstatedir, but the GNU folks recommend $(prefix)/var.
+       #   http://www.gnu.org/prep/standards/html_node/Directory-Variables.html
+       # Comedi expects to be configured with the GNU form, otherwise we
+       # get /var/lib/lib/comedi.
+       econf --localstatedir="${EPREFIX}"/var
+}
+
+src_install()
+{
+       emake DESTDIR="${D}" install
+       dodoc README AUTHORS ChangeLog
+       # make the calibration directory available to the comedi group set
+       # up by sci-misc/comedi-headers
+       chgrp comedi "${D}/var/lib/comedi/calibrations"
+       chmod 775 "${D}/var/lib/comedi/calibrations"
+}