net-wireless/bluez: Backport lots of fixes (from Fedora)...
[gentoo.git] / net-wireless / hostapd / hostapd-9999.ebuild
index 7cf65530325cb46efde23aa04ecace1196c6020c..382256f224b1855701b86a19a3ac7c372cc95f9a 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
 
-inherit toolchain-funcs eutils systemd savedconfig
+inherit toolchain-funcs systemd savedconfig
 
 DESCRIPTION="IEEE 802.11 wireless LAN Host AP daemon"
 HOMEPAGE="http://w1.fi"
-EXTRAS_VER="2.6-r5"
+EXTRAS_VER="2.7-r2"
 EXTRAS_NAME="${CATEGORY}_${PN}_${EXTRAS_VER}_extras"
 SRC_URI="https://dev.gentoo.org/~andrey_utkin/distfiles/${EXTRAS_NAME}.tar.xz"
 
@@ -15,8 +15,13 @@ if [[ $PV == 9999 ]]; then
        inherit git-r3
        EGIT_REPO_URI="https://w1.fi/hostap.git"
 else
-       SRC_URI+="https://w1.fi/releases/${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+       if [[ $PV =~ ^.*_p[0-9]{8}$ ]]; then
+               SRC_URI+=" https://dev.gentoo.org/~andrey_utkin/distfiles/${P}.tar.xz"
+       else
+               SRC_URI+=" https://w1.fi/releases/${P}.tar.gz"
+       fi
+       # Never stabilize snapshot ebuilds please
+       KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86"
 fi
 
 LICENSE="BSD"
@@ -86,7 +91,7 @@ src_configure() {
        echo "CONFIG_ERP=y" >> ${CONFIG}
        echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
 
-       if use internal-tls && !use libressl; then
+       if use internal-tls && ! use libressl; then
                echo "CONFIG_TLS=internal" >> ${CONFIG}
        else
                # SSL authentication methods
@@ -187,7 +192,7 @@ src_configure() {
 src_compile() {
        emake V=1
 
-       if use libressl || !use internal-tls; then
+       if use libressl || ! use internal-tls; then
                emake V=1 nt_password_hash
                emake V=1 hlr_auc_gw
        fi
@@ -202,7 +207,7 @@ src_install() {
        dosbin ${PN}
        dobin ${PN}_cli
 
-       if use libressl || !use internal-tls; then
+       if use libressl || ! use internal-tls; then
                dobin nt_password_hash hlr_auc_gw
        fi