*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / net-p2p / torrentinfo / torrentinfo-1.8.6-r1.ebuild
index 5474e996bcb51e932219eabbc1f9a61c7e303850..4b8f21ae7e104e22286d894a88621e31e7273e7f 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_{5,6}} pypy{,3} )
 
 inherit distutils-r1
 
@@ -12,8 +12,9 @@ SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.t
 
 LICENSE="GPL-2+"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]