*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / net-irc / limnoria / limnoria-99999999.ebuild
index 1d27fd64a1fad40dcea3ff42d58127cbfc37e833..87f53168aaae937cfc55bf3b37bed26f5e509ef9 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -12,7 +11,7 @@ MY_PN="Limnoria"
 MY_P="${MY_PN}-${MY_PV}"
 
 if [[ ${PV} == "99999999" ]]; then
-       EGIT_REPO_URI="git://github.com/ProgVal/Limnoria.git"
+       EGIT_REPO_URI="https://github.com/ProgVal/${MY_PN}.git"
        EGIT_BRANCH="testing"
        inherit git-r3
        SRC_URI=""
@@ -23,7 +22,7 @@ else
 fi
 
 DESCRIPTION="Python based extensible IRC infobot and channel bot"
-HOMEPAGE="http://supybot.aperio.fr/"
+HOMEPAGE="https://supybot.aperio.fr/"
 LICENSE="BSD"
 SLOT="0"
 IUSE="crypt ssl test"
@@ -44,6 +43,8 @@ RDEPEND="
 DEPEND="${RDEPEND}
        test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
 
+RESTRICT="!test? ( test )"
+
 src_unpack() {
        if [[ ${PV} == "99999999" ]]; then
                git-r3_src_unpack
@@ -53,7 +54,6 @@ src_unpack() {
 }
 
 python_prepare(){
-       distutils-r1_python_prepare
        if python_is_python3; then
                einfo "Removing the RSS plugin because of clashes between libxml2's Python3"
                einfo "bindings and feedparser."
@@ -69,13 +69,12 @@ python_install_all() {
 python_test() {
        pushd "${T}" > /dev/null
        PLUGINS_DIR="${BUILD_DIR}/lib/supybot/plugins"
-       # recommended by upstream, unknown random failure
-       EXCLUDE_PLUGINS=( --exclude="${PLUGINS_DIR}/Scheduler" )
-       # recommended by upstream, unknown random failure
-       EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Filter" )
+       EXCLUDE_PLUGINS=()
        # intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
        # runs successfully when running the tests on the installed system
        EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Unix" )
+       # Runs despite --no-network (GH #1392)
+       EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Aka" )
        "${PYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
                --plugins-dir="${PLUGINS_DIR}" --no-network \
                --disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \