net-ftp/tftp-hpa: fix build with gcc-10
[gentoo.git] / net-ftp / tftp-hpa / tftp-hpa-5.2-r1.ebuild
index a0de442dd025c308ba7de9f4344acc65b2505436..78723b2d830fc1f694566abd76585836546b2caf 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -7,11 +7,11 @@ inherit systemd eutils toolchain-funcs
 
 DESCRIPTION="port of the OpenBSD TFTP server"
 HOMEPAGE="https://www.kernel.org/pub/software/network/tftp/"
-SRC_URI="mirror://kernel/software/network/tftp/${PN}/${P}.tar.xz"
+SRC_URI="https://www.kernel.org/pub/software/network/tftp/${PN}/${P}.tar.xz"
 
 LICENSE="BSD-4"
 SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~ppc-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-macos"
 IUSE="ipv6 readline selinux tcpd"
 
 CDEPEND="
@@ -24,7 +24,9 @@ DEPEND="${CDEPEND}
 RDEPEND="${CDEPEND}
        selinux? ( sec-policy/selinux-tftp )
 "
+
 src_prepare() {
+       epatch "${FILESDIR}"/tftp-hpa-5.2-gcc-10.patch
        epatch_user
 
        sed -i "/^AR/s:ar:$(tc-getAR):" MCONFIG.in || die