media-sound/lilypond: remove old
[gentoo.git] / media-sound / lilypond / lilypond-9999.ebuild
index 009d9e36e6d743631c2cbb256212887a40f90d57..2a3aaafdadd4803f4878352f62193c78f54f4a8d 100644 (file)
@@ -1,13 +1,19 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 PYTHON_COMPAT=( python2_7 )
 
-inherit elisp-common autotools eutils git-r3 python-single-r1
+[[ "${PV}" = "9999" ]] && inherit git-r3
+inherit elisp-common autotools python-single-r1
 
-EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
+if [[ "${PV}" = "9999" ]]; then
+       EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
+else
+       SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~hppa ~x86"
+fi
 
 DESCRIPTION="GNU Music Typesetter"
 HOMEPAGE="http://lilypond.org/"
@@ -19,7 +25,7 @@ IUSE="debug emacs profile vim-syntax ${LANGS// / linguas_}"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND=">=app-text/ghostscript-gpl-8.15
-       >=dev-scheme/guile-1.8.2[deprecated,regex]
+       >=dev-scheme/guile-1.8.2:12[deprecated,regex]
        media-fonts/tex-gyre
        media-libs/fontconfig
        media-libs/freetype:2
@@ -29,12 +35,14 @@ RDEPEND=">=app-text/ghostscript-gpl-8.15
 DEPEND="${RDEPEND}
        app-text/t1utils
        dev-lang/perl
+       dev-libs/kpathsea
+       >=dev-texlive/texlive-metapost-2013
        || (
-               ( >=dev-texlive/texlive-metapost-2013 >=dev-tex/metapost-1.803 )
-               <dev-texlive/texlive-metapost-2013
+               >=app-text/texlive-core-2013
+               >=dev-tex/metapost-1.803
        )
        virtual/pkgconfig
-       media-gfx/fontforge
+       media-gfx/fontforge[png]
        >=sys-apps/texinfo-4.11
        >=sys-devel/bison-2.0
        sys-devel/flex
@@ -44,6 +52,8 @@ DEPEND="${RDEPEND}
 # Correct output data for tests isn't bundled with releases
 RESTRICT="test"
 
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
+
 pkg_setup() {
        # make sure >=metapost-1.803 is selected if it's installed, bug 498704
        if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
@@ -57,6 +67,8 @@ pkg_setup() {
 }
 
 src_prepare() {
+       default
+
        if ! use vim-syntax ; then
                sed -i 's/vim//' GNUmakefile.in || die
        fi
@@ -81,13 +93,18 @@ src_configure() {
        # documentation generation currently not supported since it requires a newer
        # version of texi2html than is currently in the tree
 
-       econf \
-               --with-texgyre-dir=/usr/share/fonts/tex-gyre \
-               --disable-documentation \
-               --disable-optimising \
-               --disable-pipe \
-               $(use_enable debug debugging) \
+       local myeconfargs+=(
+               --with-texgyre-dir=/usr/share/fonts/tex-gyre
+               --disable-documentation
+               --disable-optimising
+               --disable-pipe
+               $(use_enable debug debugging)
                $(use_enable profile profiling)
+       )
+
+       has_version ">=dev-scheme/guile-2" && myeconfargs+=( --enable-guile2 )
+
+       econf "${myeconfargs[@]}"
 }
 
 src_compile() {
@@ -113,7 +130,7 @@ src_install () {
 
        python_fix_shebang "${ED}"
 
-       dodoc HACKING README.txt
+       einstalldocs
 }
 
 pkg_postinst() {