*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / media-libs / musicbrainz / musicbrainz-5.1.0.ebuild
index f8f09eb468ed67cc7c7bf683c6b53cdbcece4448..ea6694fb386f173f54a9568109564f9e15f47529 100644 (file)
@@ -1,18 +1,19 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
 
 DESCRIPTION="Client Library for accessing the latest XML based MusicBrainz web service"
-HOMEPAGE="http://musicbrainz.org/doc/libmusicbrainz"
+HOMEPAGE="https://musicbrainz.org/doc/libmusicbrainz"
 SRC_URI="https://github.com/metabrainz/lib${PN}/releases/download/release-${PV}/lib${P}.tar.gz"
 
 LICENSE="LGPL-2.1"
 SLOT="5/1"     # soname of libmusicbrainz5.so
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
 IUSE="examples test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        dev-libs/libxml2
@@ -24,6 +25,18 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/lib${P}"
 
+src_prepare() {
+       use test || cmake_comment_add_subdirectory tests
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       # bug 619668
+       append-cxxflags -std=c++14
+
+       cmake-utils_src_configure
+}
+
 src_install() {
        cmake-utils_src_install