media-libs/kvazaar-1.2.0-r1: alpha stable
[gentoo.git] / media-libs / libreplaygain / libreplaygain-477-r1.ebuild
index dea0a187b39609278d0075c472ba4046db312134..b0c94883cfbdd672663a82f1daad780b2cefc25a 100644 (file)
@@ -1,25 +1,25 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI=5
+EAPI=6
+
 inherit cmake-multilib
 
 # svn export http://svn.musepack.net/libreplaygain libreplaygain-${PV}
 # tar -cJf libreplaygain-${PV}.tar.xz libreplaygain-${PV}
 
 DESCRIPTION="Replay Gain library from Musepack"
-HOMEPAGE="http://www.musepack.net/"
+HOMEPAGE="https://www.musepack.net/"
 SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
 
 LICENSE="LGPL-2.1"
 SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
 IUSE=""
-RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r2
-               !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
 
 src_prepare() {
+       cmake-utils_src_prepare
+
        sed -i -e '/CMAKE_C_FLAGS/d' CMakeLists.txt || die
 }