*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / media-libs / libglvnd / libglvnd-1.3.0.ebuild
index 49a9c99cac8476b9601c1a1fe33b58f69222134b..cb18f71aa5c263e824bb21f5b2668c6ecec2238a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 2018-2019 Gentoo Authors
+# Copyright 2018-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
        GIT_ECLASS="git-r3"
 fi
 
-PYTHON_COMPAT=( python3_{5,6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 VIRTUALX_REQUIRED=manual
 
 inherit ${GIT_ECLASS} meson multilib-minimal python-any-r1 virtualx
@@ -19,7 +19,7 @@ HOMEPAGE="https://gitlab.freedesktop.org/glvnd/libglvnd"
 if [[ ${PV} = 9999* ]]; then
        SRC_URI=""
 else
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
        SRC_URI="https://gitlab.freedesktop.org/glvnd/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
        S=${WORKDIR}/${PN}-v${PV}
 fi