*/*: Bump copyright on files touched this year
[gentoo.git] / media-gfx / pstoedit / pstoedit-3.70-r1.ebuild
index 605b09d79e92d67aae0f34e7c55517e1dee64800..7fff681c0e9c2f107811d1bd26876bc95703594e 100644 (file)
@@ -1,10 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI=5
+EAPI=6
 
-inherit autotools eutils
+inherit autotools
 
 DESCRIPTION="Translate PostScript and PDF graphics into other vector formats"
 HOMEPAGE="https://sourceforge.net/projects/pstoedit/"
@@ -12,14 +11,13 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="emf flash imagemagick plotutils pptx static-libs"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="emf imagemagick plotutils pptx static-libs"
 
 RDEPEND="
        >=media-libs/gd-2.0.35-r1:=
        >=app-text/ghostscript-gpl-8.71-r1
        emf? ( >=media-libs/libemf-1.0.3 )
-       flash? ( >=media-libs/ming-0.4.3 )
        imagemagick? ( >=media-gfx/imagemagick-6.6.1.2[cxx] )
        plotutils? ( media-libs/plotutils )
        pptx? ( dev-libs/libzip )
@@ -28,15 +26,19 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
 "
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.60-libdl.patch
+       "${FILESDIR}"/${PN}-3.70-pkgconfig.patch
+)
+
 src_prepare() {
+       default
+
        sed -i \
                -e '/CXXFLAGS="-g"/d' \
                -e 's:-pedantic::' \
                configure.ac || die
 
-       epatch "${FILESDIR}"/${PN}-3.60-libdl.patch
-       epatch "${FILESDIR}"/${PN}-3.70-pkgconfig.patch
-
        eautoreconf
 }
 
@@ -46,15 +48,16 @@ src_configure() {
                $(use_with emf) \
                $(use_with imagemagick magick) \
                $(use_with plotutils libplot) \
-               $(use_with flash swf) \
-               $(use_with pptx)
+               $(use_with pptx) \
+               --without-swf
 }
 
 src_install() {
        default
        doman doc/pstoedit.1
        dodoc doc/*.txt
-       dohtml doc/*.htm
+       docinto html
+       dodoc doc/*.htm
 
        find "${ED}" -name '*.la' -delete
 }